dead battery

This is a discussion on dead battery within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; Hey guys, wandering if anybody has experienced a dead battery. I bought a 2013 ecboost it has 2900 miles on it. I went to drive ...

Page 1 of 2 12 LastLast
Results 1 to 10 of 20

Thread: dead battery

  1. #1
    Rookie perk2013's Avatar
    Join Date
    Jun 2013
    Location
    NORTH CAROLINA
    Posts
    1
    Member #
    1294

    dead battery

    Hey guys, wandering if anybody has experienced a dead battery. I bought a 2013 ecboost it has 2900 miles on it. I went to drive it last night and nothing happened everthing was dead. I haven't drove it in a couple of days nothing was left on or pluged up to drain the battery. I wasn't able to figure out what might have drained battery.

    Thanks for any helpful info

  2. #2
    Ecoboost Pro spyder982's Avatar
    Join Date
    Aug 2013
    Posts
    668
    Member #
    1958
    Liked
    116 times
    May just be bad. Not likely but if they have sat a long time on the lot and rarely driven it may be weak. Once you jump it off and get it running again id look for any interior lights left on. If it continues to start fine then you're probably fine.

  3. #3
    Ecoboost Master Grim Reaper's Avatar
    Join Date
    Aug 2013
    Location
    Future Republic of North Western English Columbia
    Posts
    1,286
    Member #
    1898
    Liked
    457 times
    Quote Originally Posted by spyder982 View Post
    May just be bad. Not likely but if they have sat a long time on the lot and rarely driven it may be weak. Once you jump it off and get it running again id look for any interior lights left on. If it continues to start fine then you're probably fine.
    You may be onto something there. The poster doesn't mention which truck, but his "timer" to turn off the lights (after turning off the vehicle) may be set high and it's draining his battery (if he hasn't driven very far).

    Check your settings for turning off the lights (after stopping the truck) and set it to the shortest time interval.
    2013 F-150 4x4 Supercab 145"WB Ecoboost XLT, Group 302A, XTR Trailer Package, E-Lock 3.55s, 36 Gallon Fuel Tank ... not quite a virgin anymore



  4. #4
    Ecoboost Jr Member Sierra1's Avatar
    Join Date
    Jan 2013
    Location
    Paola, Kansas
    Posts
    29
    Member #
    277
    Liked
    3 times
    Quote Originally Posted by perk2013 View Post
    Hey guys, wandering if anybody has experienced a dead battery. I bought a 2013 ecboost it has 2900 miles on it. I went to drive it last night and nothing happened everthing was dead. I haven't drove it in a couple of days nothing was left on or pluged up to drain the battery. I wasn't able to figure out what might have drained battery.

    Thanks for any helpful info
    My 2013 did the same thing to me after sitting over night...no obvious reason for it to happen, and hasn't done it since.
    Joe Reif
    Paola, Kansas
    Email: joereif1970@gmail.com
    2013 F150 ecoboost, crew cab, 4x4, max trailer tow, heavy 1/2 ton
    2014 Polaris RZR XP1000 2 seater
    2011 Tahoe PPV
    2007 Harley Davidson Road King 103" Screaming Eagle
    2005 Subaru Impreza WRX STi sedan 163k miles
    2003 Mustang Cobra 10th anniversary edition convertible 26k miles
    2002 Corvette Z06 Electron blue with black leather 29k miles

  5. #5
    Eco-Beast Raiderfan1890's Avatar
    Join Date
    Feb 2013
    Location
    Napa, CA
    Posts
    5,234
    Member #
    477
    Liked
    2256 times
    That's weird. I left the ignition on once and it automatically cut everything off as a battery saving feature. It saved me from having to jump it.
    2013 Sterling Gray FX4 157", Appearance Package, Max Tow, 402a, 36 Gallon Tank, 52k miles.
    Mods: S&B intake, FR resonated exhaust, X4 with LET and MPT tunes, auxiliary backup lights.
    To be installed: 170* tstat, AEM meth injection.
    On order: FR CAC ( black anodized, red tial bov, throttle body spacer, meth bung)

  6. #6
    Ecoboost Jr Member BLUEOVALRACER's Avatar
    Join Date
    Jun 2013
    Location
    Ohio
    Posts
    37
    Member #
    1527
    Liked
    3 times
    Could just be a bad battery,i had a Ranger years ago.I went to leave the driveway and stalled it,i went to restart it and it wouldn't start.I took the battery to the Ford dealer and they said it must have had a short in it.

    Later Mark.

  7. #7
    Ecoboost Regular Snowdog's Avatar
    Join Date
    May 2013
    Location
    SW PA
    Posts
    145
    Member #
    1216
    Liked
    23 times
    We had the same thing happen to our Dodge. I know, a Ford forum but wanted to share. Drove it for a year with no issues. Took it from Pittsburgh to Salem MA, parked it in front of the hotel and wasn't planning on moving it. Went to get stuff 2 days later and it had issues locking the door and the horn was trying to pathetically alarm. The dealers in the area were less than helpful as it was still in the 3/36 warranty. Bought a new battery, took the old one back to our local dealer who took their sweet time paying us back for the new battery and said they found nothing wrong with the old one. That truck also would turn off any electronic devices if they were left on. Never had any other issues and traded it with the new battery. My guess is the same as in your case, something stuck on and drained it and when it started to operate again things went back to normal. Honestly with all the electronics these days I'm surprised that batteries aren't dying more frequently.

  8. #8
    Ecoboost Jr Member Sierra1's Avatar
    Join Date
    Jan 2013
    Location
    Paola, Kansas
    Posts
    29
    Member #
    277
    Liked
    3 times
    Now mine has done the dead battery deal twice on me in 1 month.....it's going back to the dealer ASAP.
    Joe Reif
    Paola, Kansas
    Email: joereif1970@gmail.com
    2013 F150 ecoboost, crew cab, 4x4, max trailer tow, heavy 1/2 ton
    2014 Polaris RZR XP1000 2 seater
    2011 Tahoe PPV
    2007 Harley Davidson Road King 103" Screaming Eagle
    2005 Subaru Impreza WRX STi sedan 163k miles
    2003 Mustang Cobra 10th anniversary edition convertible 26k miles
    2002 Corvette Z06 Electron blue with black leather 29k miles

  9. #9
    Rookie stang7606's Avatar
    Join Date
    Sep 2013
    Posts
    1
    Member #
    2283
    Quote Originally Posted by Sierra1 View Post
    Now mine has done the dead battery deal twice on me in 1 month.....it's going back to the dealer ASAP.

    I am new here, but have had the same issue last Monday and Wednesday. The Wednesday one could have been insufficient charge from Monday, but there was no explanation Monday. No lights left on, nothing plugged in, light delay set to 0. Out only has 1700 miles and an carrying around a spare battery in the bed. The dealer could find nothing wrong, but that doesn't mean a lot. Just sharing my experience.

  10. #10
    Rookie osprey's Avatar
    Join Date
    Sep 2013
    Location
    Wisconsin
    Posts
    1
    Member #
    2401
    I am new here as well and joined to monitor and help if possible on the issue in this post, it sounds like the problem I'm having with my 2013 F150. Twice now in the past 2 months I've jumped in my truck and found my battery to be completely dead...not enough juice to power the dome light. My truck is still well under warranty so I will be taking it in, since the problem is so intermittent I expect to get the same answer as "stang7606". So here's my story; both times I've had this has happen I had driven the truck the day previously and parked it in the garage, I wrote it off as having left something on even though I didn't find anything...now this morning I had the same exact issue...I used the truck yesterday, all doors were closed and lights in cab appeared to be off, I don't use the Auto headlight setting so headlights were also switched to off position. I'd appreciate any insight or answers.

Page 1 of 2 12 LastLast

Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Payload issues, shudder from a dead stop.
    By Juice man in forum F150 Ecoboost Problems
    Replies: 33
    Last Post: 12-15-2013, 05:13 PM
  2. system is shutting down to protect battery life.
    By olehoss in forum F150 Ecoboost Chat
    Replies: 12
    Last Post: 03-26-2013, 06:16 PM
  3. system is shutting down to protect battery life.
    By olehoss in forum F150 Ecoboost News
    Replies: 7
    Last Post: 02-11-2013, 09:55 AM

Search tags for this page

2013 f150 battery drain

,

2013 f150 battery problems

,

2013 f150 dead battery

,
2013 ford f150 battery dead
,
2013 ford f150 battery problems
,

2013 ford f150 dead battery

,
f150 dead battery
,
ford f150 battery problems
Click on a term to search for related topics.
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+