high beams not working

high beams not working

This is a discussion on high beams not working within the F150 Ecoboost Maintenance forums, part of the F150 Ecoboost Garage category; my low beams work fine but i have no high beams, i checked the fuse at the passenger door kick panel and it looks fine....any ...

Results 1 to 5 of 5
Like Tree1Likes
  • 1 Post By Yake Bait

Thread: high beams not working

  1. #1
    Ecoboost Jr Member Vectorboost's Avatar

    Join Date
    May 2014
    Location
    Tallahassee, Florida
    Posts
    30
    Member #
    5200
    Liked
    8 times

    high beams not working

    my low beams work fine but i have no high beams, i checked the fuse at the passenger door kick panel and it looks fine....any ideas?....the high beams light on the dashboard comes on but thats it

  2. #2
    Ecoboost Veteran Yake Bait's Avatar

    Join Date
    Jan 2013
    Location
    Upper Michigan
    Posts
    311
    Member #
    310
    Liked
    90 times
    HID or halogens?

    The high and low beams have separate fuses for each. Halogens are beneath the glove box. HID under the hood.
    mc4100s2 likes this.
    2017 Ruby Red F-150 XLT FX4 SCREW - 145" WB - 3.5L EB - 3.55 gears

    Jay Flight Swift 267BHS
    Blue Ox SwayPro Hitch

  3. #3
    Ecoboost Jr Member Vectorboost's Avatar

    Join Date
    May 2014
    Location
    Tallahassee, Florida
    Posts
    30
    Member #
    5200
    Liked
    8 times
    standard halogens and the fuse under the glovebox that the manual says is for high beams checks out ok

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #4
    Eco-Beast akmedic77's Avatar

    Join Date
    Feb 2013
    Location
    South Central Alaska
    Posts
    2,504
    Member #
    421
    Liked
    678 times
    Try changing the bulbs. Maybe you lost both filaments for the high beams.
    2013 Oxford White FX4 CCSB | 402A | 3.55 | S&B CAI & BBK TB | Leer Cap w/DZ TG Assist | DD 3.0 | Tint, Brow, Pinstripe | Interior LED Swap | OEM HD Flaps | Cold Weather Front & Winterization | Arc Rite Brush Guard & Rigid Lighting| JW Speaker 6146 Fogs | Build Thread

    2008 Black Slate Pearl Mariner Premier | 303A | Moon & Tune | PIAA Heads/Fogs | Cold Weather Front & Winterization



  6. #5
    Ecoboost Jr Member Vectorboost's Avatar

    Join Date
    May 2014
    Location
    Tallahassee, Florida
    Posts
    30
    Member #
    5200
    Liked
    8 times
    sadly the dealership checked it out and i actually have 2 bad bulbs, i woulda never figured both would go bad sooon..... 3 months old. i think they were pilot brand h13 bulbs. dealer didnt charge me or give me any grief about my bull bar of the f150.

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Hi Beams Mod?
    By Specs3.5 in forum F150 Ecoboost Appearance
    Replies: 21
    Last Post: 05-19-2019, 08:10 PM
  2. Hi Beams Mod?
    By Specs3.5 in forum F150 Ecoboost Chat
    Replies: 20
    Last Post: 05-19-2019, 02:36 PM
  3. High beams/fog lights
    By kFirm in forum F150 Ecoboost Electronics
    Replies: 28
    Last Post: 05-18-2019, 07:32 PM
  4. Turn signals/high beams not working
    By DB Cooper in forum F150 Ecoboost Problems
    Replies: 2
    Last Post: 03-07-2014, 10:02 PM
  5. Trailer Connection Not Working
    By randomwalker in forum F150 Ecoboost Towing
    Replies: 4
    Last Post: 02-05-2013, 08:40 AM

Search tags for this page

2008 f150 fx4 no high beams
,
2008 f150 high beams quit
,

2013 f150 fog lights on with high beams

,

f150 high beams not working

Click on a term to search for related topics.
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+