None of my faucets work on my Trailer - Page 2

None of my faucets work on my Trailer

This is a discussion on None of my faucets work on my Trailer within the F150 Ecoboost Towing forums, part of the F150 Ecoboost Forum category; Did you fill them with water?...

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
Like Tree2Likes

Thread: None of my faucets work on my Trailer

  1. #11
    Ecoboost Master Envious's Avatar

    Join Date
    Dec 2015
    Location
    Colorado
    Posts
    1,165
    Member #
    14405
    Liked
    425 times
    Did you fill them with water?
    2013 FX4 - Black Betty
    Boostking Tuned

  2. #12
    Ecoboost Sr Member {tpc}'s Avatar

    Join Date
    Aug 2018
    Location
    Berkley, MI
    Posts
    79
    Member #
    66606
    Liked
    17 times
    When you say filters, are they the replaceable inline type filters? Like a "whole house" style or something? I would bet thats where the chunks of stuff came from, its probably calcium buildup or something that hardened up while sat over the winter.

    As for winterizing, I'm paranoid. Not so much that I'll pay the dealer $150 to do it (though I have in a pinch to save time), but enough that I blow the lines out with the air-compressor AND I run antifreeze through the system. Air is free, antifreeze is cheap, process is easy, just have to have the time to do it is all.
    2018 Magnetic F150 XLT SuperCrew 2.7l Ecoboost/302A

  3. #13
    Eco-Beast mass-hole's Avatar

    Join Date
    Feb 2015
    Location
    UT
    Posts
    3,089
    Member #
    8316
    Liked
    1092 times

    None of my faucets work on my Trailer

    Quote Originally Posted by {tpc} View Post
    When you say filters, are they the replaceable inline type filters? Like a "whole house" style or something? I would bet thats where the chunks of stuff came from, its probably calcium buildup or something that hardened up while sat over the winter.

    As for winterizing, I'm paranoid. Not so much that I'll pay the dealer $150 to do it (though I have in a pinch to save time), but enough that I blow the lines out with the air-compressor AND I run antifreeze through the system. Air is free, antifreeze is cheap, process is easy, just have to have the time to do it is all.
    No, these were these little plastic discs inside the faucet sitting just above the screen/aerator. Honestly, they may not be filters, it may be a flow regulator like they put on shower heads now. Either way they had a VERY thin gap for the water to pass through and it plugged up.

    I left them removed so i will try to grab a picture.
    2014 Lariat Screw, 157", Max Tow, 502A - Gearhead Tuned, AFE Intercooler, RX Catch Can, Bilstein 5100(.8" level), AirLift RideControl bags, 275/60R20 Wrangler Duratracs

    2006 Jeep Liberty CRD(diesel) - GDE Tune, Straight piped, AFE filter, 2.5" Lift, ARB bumper

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #14
    Ecoboost Regular Kinguni's Avatar

    Join Date
    Mar 2016
    Location
    Lorette, MB
    Posts
    103
    Member #
    15424
    Liked
    26 times
    Quote Originally Posted by mass-hole View Post
    No, these were these little plastic discs inside the faucet sitting just above the screen/aerator. Honestly, they may not be filters, it may be a flow regulator like they put on shower heads now. Either way they had a VERY thin gap for the water to pass through and it plugged up.
    Flow regulator. Standard part of every aerator. Cleaning your aerators at least once a yer is a good idea.
    2018 3.5 XLT 302a XTS SCREW LB Max Tow Magnetic No Mods

  6. #15
    Ecoboost Regular SuperDave23's Avatar

    Join Date
    Jul 2017
    Location
    Fresno, CA
    Posts
    179
    Member #
    40369
    Liked
    32 times
    Might be crap from your water heater. I bought my trailer used (~10 yrs old) and when I pulled the anode rod to inspect what was left of it (the rod was down to 14-gauge wire thickness!) there was a ton of white calcium pieces in the bottom. I shop-vac'd a bunch out. Don't think the anode was ever changed or the heater was ever cleaned out.
    Dave
    2013 F150 4x4 EB
    2005 F250 4x4 6.0 Sold
    2002 F150 4x4 5.4 Sold

  7. #16
    Gold Supporting Member snakebitten's Avatar
    Gold Member

    Join Date
    Dec 2017
    Location
    Coastal Texas
    Posts
    3,740
    Member #
    52137
    Liked
    3091 times
    I'm still convinced (which doesn't mean much) that it was "new construction debris" that found its way into the plumbing system.

    I only think that from buying a couple of RV's new and discovering stuff in wierd places that were trapped and left there in the HASTE of the typical assembly line.

    Watch a few legitimate (not marketing) YouTube videos of RV manufacturing. It's actually hilarious.

    Sent from my SM-N950U using Tapatalk
    2018 KingRanch Kingsville Edition- Gen2 3.5 - Runs SO good on Factory tunes. Simply amazing. Good Job Ford

Page 2 of 2 FirstFirst 12

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 64
    Last Post: 01-29-2018, 06:30 PM
  2. Left brake/turn light does not work on trailer
    By GDSQDCR in forum F150 Ecoboost Towing
    Replies: 2
    Last Post: 03-24-2017, 07:45 AM
  3. Just towed my work trailer
    By GDSQDCR in forum F150 Ecoboost Towing
    Replies: 4
    Last Post: 03-24-2015, 06:44 AM
  4. Trailer brakes and aux lights don't work
    By Sherman in forum Off-Topic
    Replies: 5
    Last Post: 05-27-2014, 04:07 AM
  5. Trailer power tongue jack doesn't work
    By REVF150 in forum F150 Ecoboost Chat
    Replies: 24
    Last Post: 05-19-2014, 06:45 PM
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+