Clock Flashes/Radio Inop

Clock Flashes/Radio Inop

This is a discussion on Clock Flashes/Radio Inop within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; Got in my 2011 Monday morning and I noticed the clock was flashing, it is a random flash. The radio will not turn on and ...

Page 1 of 3 123 LastLast
Results 1 to 10 of 21
  1. #1
    Rookie pminnc's Avatar

    Join Date
    Aug 2016
    Location
    Charlotte
    Posts
    15
    Member #
    19689
    Liked
    2 times

    Clock Flashes/Radio Inop

    Got in my 2011 Monday morning and I noticed the clock was flashing, it is a random flash. The radio will not turn on and bluetooth/sync is also inop. Any ideas or suggestions? Thanks in advance!!

  2. #2
    Ecoboost Pro aj.n.amber's Avatar

    Join Date
    Feb 2016
    Location
    Lockport, NY
    Posts
    660
    Member #
    14906
    Liked
    108 times
    Recently tuned? I saw because that happened to me once when I flashed a tune in... had to put it in stock for the radio to stop flashing.

    Sent from my SM-G950U using Tapatalk
    2011 F150 XLT XTR 3.73 SuperCrew Ecoboost.... w/Tow Package w/o Payload Package...

  3. #3
    Rookie pminnc's Avatar

    Join Date
    Aug 2016
    Location
    Charlotte
    Posts
    15
    Member #
    19689
    Liked
    2 times
    Quote Originally Posted by aj.n.amber View Post
    Recently tuned? I saw because that happened to me once when I flashed a tune in... had to put it in stock for the radio to stop flashing.

    Sent from my SM-G950U using Tapatalk

    No, no tune...Sunday it was working fine, Monday...not so much.

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #4
    Gold Supporting Member Mr B's Avatar
    Gold Member

    Join Date
    Apr 2015
    Location
    LA-Lower Alabama
    Posts
    2,565
    Member #
    10715
    Liked
    1054 times
    My radio would not come on last weekend or sync voice command, so I disconnected battery for a hr or so, reconnected and everything came back on with no issues. But my clock wasn't flashing. Maybe this will work.
    @pminnc
    Last edited by Mr B; 06-07-2017 at 05:13 PM.

    2013 F150 Supercrew Lariat+ | Kodiac Brown | 4X4 | 502A | Tow | 3.55 E-Locker | SCT X4 5* 93per/tow | Michelin Defender LTX M/S 285/60R20 | PowerStop slotted-drilled front and back rotors W/ Z36 pads | Bilsteins 5100's X4 |Hellwig rear Anti-Sway Bar | Firestone Ride-Rite Rear Airbags (5000) | Air Lift WirelessAIR On-Board Air Compressor (7200) | AMP Research Power Step | spray in bed liner | HID lights | full LED | aFePower diff. Cover | 3.0 door detent | DeeZee TGA | Retrax Pro Cover | Rugged Ridge FM | Anzo LED side Mirror lights | UPR Billet Emblems | aFePower 4"X12" black exhaust tip | OEM Rear Wheel Well Liners | Westin Contour bull bar | Rigid Industries D-Series D2 LED Lights | raptor grill lights | SnapRest armrest | Bright TRAX led puddle lights | TrailFX window vents/hood protector | 35% tint | My Build https://www.f150ecoboost.net/forum/1...-counting.html


  6. #5
    Rookie pminnc's Avatar

    Join Date
    Aug 2016
    Location
    Charlotte
    Posts
    15
    Member #
    19689
    Liked
    2 times
    Quote Originally Posted by Mr B View Post
    My radio would not come on last weekend or sync voice command, so I disconnected battery for a hr or so, reconnected and everything came back on with no issues. But my clock wasn't flashing. Maybe this will work.
    @pminnc
    I will give it a shot....found some info on the APIM or the ACM, neither one are cheap fixes.

  7. #6
    Ecoboost Jr Member mtucker636's Avatar

    Join Date
    Feb 2013
    Location
    Cato, NY
    Posts
    24
    Member #
    414
    Liked
    3 times
    I am currently having this same issue. I will be driving down the road and the radio will pop and then shut off. Sometimes it comes back on, other times if I hit the power button to turn it off and then again to turn it back on it will keep working and most of the time now it just stays off and the clock flashes. When it first started happening I could turn the truck off and back on and it would go back to normal. Now it seems to have a mind of its own when it going to work again. 20 minutes later still driving down the road it might come back on. I asked a buddy who works at a ford dealership and he said the radio s probably bad. He said the stock radios are junk and that they replace them all the time.
    I like the setup of my stock radio though so am looking into getting mine fixed (or buying a new or used one off ebay)

    Glad to hear im not the only one who is having this issue though

  8. #7
    Ecoboost Jr Member mtucker636's Avatar

    Join Date
    Feb 2013
    Location
    Cato, NY
    Posts
    24
    Member #
    414
    Liked
    3 times
    So update on my radio. I pulled the radio out and took it in to United Radio (Electronics repair place near me) They had to re-solder some connections and the radio is now working with no issues. It cost 172 dollars to have them fix it but I like my stock radio (really I just like the 10 presets for the radio) and it comes with a 1 year warranty. I dropped it off after work Thursday and they had it fixed less than 2 hours later. Picked it up Friday and had it back in the truck just after I got home.

  9. #8
    Rookie pminnc's Avatar

    Join Date
    Aug 2016
    Location
    Charlotte
    Posts
    15
    Member #
    19689
    Liked
    2 times
    update for my issue....On the Monday that I noticed the issue I was on my way to the airport for a week long trip. When I returned and got into the truck on the following Friday everything worked as advertised...no issues what so ever. Fast forward a week and half, on my way to the store tonight and I noticed the clock was flashing again. Pulled the radio fuse, disconnected the battery and the problem remained. Gave the front of the radio a good old fashion "b*tch Slap" and it started working. I might be looking at the same problem that MTucker had. I too am perfectly content with the stock radio if it will work.

  10. #9
    Rookie pminnc's Avatar

    Join Date
    Aug 2016
    Location
    Charlotte
    Posts
    15
    Member #
    19689
    Liked
    2 times
    Quote Originally Posted by mtucker636 View Post
    So update on my radio. I pulled the radio out and took it in to United Radio (Electronics repair place near me) They had to re-solder some connections and the radio is now working with no issues. It cost 172 dollars to have them fix it but I like my stock radio (really I just like the 10 presets for the radio) and it comes with a 1 year warranty. I dropped it off after work Thursday and they had it fixed less than 2 hours later. Picked it up Friday and had it back in the truck just after I got home.
    thanks for the update

  11. #10
    Ecoboost Jr Member mtucker636's Avatar

    Join Date
    Feb 2013
    Location
    Cato, NY
    Posts
    24
    Member #
    414
    Liked
    3 times
    No problem. When I first started having issues it might happen once a month. Then it was once every 2 weeks then every week to every couple of days. Undoubtedly it will get worse and worse, I stretched mine out for a good 6 months before it was starting to become consistent problem. I did look on ebay for a used radio. There were a few that would have fit and were a little cheaper but having mine fixed got me a 1 year warranty so that was worth the few extra bucks to me.

Page 1 of 3 123 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. how many flashes on your truck? i just got 55
    By taubr unit in forum F150 Ecoboost Performance
    Replies: 34
    Last Post: 10-24-2015, 04:04 PM
  2. Vision X LED back up lights rendered Reverse sensors inop
    By Jims14Screw in forum F150 Ecoboost Lighting
    Replies: 2
    Last Post: 10-14-2015, 07:23 PM
  3. Its 10 o'clock at night and I'm
    By Nasty Wendy in forum Off-Topic
    Replies: 12
    Last Post: 04-29-2015, 12:24 AM
  4. CEL flashes but not on, issue?
    By taubr unit in forum F150 Ecoboost Performance
    Replies: 8
    Last Post: 10-08-2014, 09:06 PM
  5. 2011 Ecoboost turbos inop
    By Krull in forum F150 Ecoboost Problems
    Replies: 222
    Last Post: 09-18-2014, 10:58 AM

Search tags for this page

2011 f150 radio not working
,
2011 f150 stereo not working
,
2012 ford f150 radio blinking and not working
,
2013 f150 radio stopped working
,

2013 ford f150 radio not working

,

2013 ford f150 radio problems clock flashing

,
2014 f-150 the radio quit and the clock flashes
,
2014 f150 radio problems
Click on a term to search for related topics.
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+