Light for outside mirror heater/rear defrost won't come on

Light for outside mirror heater/rear defrost won't come on

This is a discussion on Light for outside mirror heater/rear defrost won't come on within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; I know what you're thinking. It's the rear sliding glass to blame, right? Well, I think that's not it. For one, I never use the ...

Page 1 of 2 12 LastLast
Results 1 to 10 of 12
  1. #1
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times

    Light for outside mirror heater/rear defrost won't come on

    I know what you're thinking. It's the rear sliding glass to blame, right? Well, I think that's not it. For one, I never use the rear siding window. The problem is the light on the button for the rear defroster/outside mirror defrost doesn't even come on. I assume if the rear window connection was a problem I would still see the button lit up, but that doesn't even light up. According to the manual, 40A fuze un position 32 is for the rear window/outside mirror defroster and also the high power relay in position 4 is the relay associated with this. I checked/swapped the fuse and no luck. Still no light. I also swapped the relay in position 6 (same type of relay, for trailer brake lights or something) and that didn't work either.

    Any ideas?
    2014 F-150 XLT EcoBoost 4x4 with 302A Equipment Package

  2. #2
    Ecoboost Regular Sir_Boosted's Avatar

    Join Date
    Jul 2014
    Location
    DFW
    Posts
    145
    Member #
    5600
    Liked
    43 times
    Have you tried sliding your rear window all the way open and ALL the way shut. I say this because one time I didn’t fully close the rear sliding window and it did the same as what you’re saying. The light or nothing would come on from both the switch and the infotainment center. Soon as I shut the window completely everything worked as normal. If this isn’t the case, then this is over my head as I have no idea how ford has this thing wired.
    2013 Limited

  3. #3
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times
    Thanks. I tried that just a few minutes ago and no luck. Still no light. I assumed if the rear window was to blame I'd still see the light on the button come on, but I could be wrong. You guys that have had that problem would know better than me. Oh well, I'll keep messing with it in my spare time and I hope it's something simple. I don't know if I want to pay for a big repair, but I really do need that for winter.

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #4
    Ecoboost Regular R0bCincy's Avatar

    Join Date
    Apr 2018
    Location
    Cincinnati, OH
    Posts
    206
    Member #
    59570
    Liked
    56 times
    On mine it was the rear slider. Check this out... https://youtu.be/-51t4WZfqkY
    2011 FX4 SCREW, 3.5 EB. 3.73 and 5* and MPT Tunes, SW catted DP and SW 3.5 inch Chambered Exhaust, AFE Stage 2 Intake, Mishimoto CAC, and very rusty cab corners.

  6. #5
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times
    Quote Originally Posted by R0bCincy View Post
    On mine it was the rear slider. Check this out... https://youtu.be/-51t4WZfqkY
    Thanks for the video. I'll use that to look over the system and hopefully it's something simple like contacts dirty on the window.

  7. #6
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times
    Any other ideas or troubleshooting tips? So far I've swapped all the fuses involved (fuses that related to the defroster in the owner's manual) and also swapped the relay in the fuse box. I took the back seat out just to have a look at the wires and everything looks perfect. I NEVER use the rear sliding window because when I bought the truck new in 2014, I had already read about the problems people had with the defroster when they use the rear slider a lot. I did however go ahead and open/close it a bunch of times in case the contacts weren't making good contact. From what I can see, it looks good and I can even still see some of that factory lube they put on the contact area for the rear slider. So, I 'think' it's not the rear window that's the problem.

    Just looking for some more ideas that I could try, if any, before I give up and pay the dealer later this year to tell me what the problem is (then I can decide to fix it myself, if I can, or have them do it). It seems like such a trivial thing, but come wintertime, I really need the heated mirrors to work.
    2014 F-150 XLT EcoBoost 4x4 with 302A Equipment Package

  8. #7
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times

    Update

    I had been reading where people say the outside mirror heaters will still work even though the rear window defroster and the light to indicate it's on is not lit up. Well, I confirmed today that this is absolutely true in my case and that's good! The mirror heater is what I needed the most anyway. It's about 73 F outside right now and I felt the mirror while driving and it was cool. I pressed the button to turn on the rear window defroster/heated mirrors and sure enough, a minute or two later the mirror was very noticeably warm to the touch. At this point, I'm not going to worry about it since the heated mirrors work. The rear glass hardly ever gets any ice on it anyway.
    2014 F-150 XLT EcoBoost 4x4 with 302A Equipment Package

  9. #8
    Ecoboost Sr Member Wyyldstang's Avatar

    Join Date
    Sep 2013
    Location
    South Carolina
    Posts
    51
    Member #
    2210
    Liked
    1 times
    just tried the back glass...no luck.....but im following for updates

  10. #9
    Ecoboost Regular lariatf150's Avatar

    Join Date
    Jun 2014
    Posts
    243
    Member #
    5458
    Liked
    73 times
    Update on this problem. I gave up trying to find a solution myself and was going to live with only the heated mirrors working and no light to indicate it's on. Well, a few days ago on my drive to work (25F), I pressed the button to defrost my mirrors because that still worked. Next thing I know, the light is on and the rear window is showing signs of heating (strips of defrosted areas along the heating elements on the window). Huh? Suddenly it works? I turned it off when I was done and when I got to work, I turned it on again to see if it comes back on consistently. This time the light came on briefly and then went off again. I pressed the button again to turn it off (because it really is on, even though the light is off). I pressed the button again to turn it on, same thing....brief light and then off again. I waited a few more minutes and turned it on again and this time it stayed on (light was on).

    I tried that again yesterday too and so far, it seems to turn on briefly and then go off, but if I try a few more times it will come on and stay on (the light - so both the mirrors and the rear window heater are on).

    I'm not sure what has changed, but I hope it keeps working.
    2014 F-150 XLT EcoBoost 4x4 with 302A Equipment Package

  11. #10
    Super Moderator milesej05's Avatar
    Gold Member

    Join Date
    Jan 2014
    Location
    Omaha, Nebraska
    Posts
    7,621
    Member #
    3552
    Liked
    3316 times
    Sounds like loose wiring.
    2018 Magnetic Metallic 2.7 Ecoboost XLT Sport
    2013 Oxford White EcoBoost FX4 - Gone

    Quote Originally Posted by noodles
    Sometimes, a fool should trust what the wise say, instead of coming out yelling Totally Not True... because you couldn't find it on google. The wise usually know what they are talking about, because of either hands on experience, or maybe they've just been around long enough to know what's what.



    Check out the following threads for most of the questions regarding the F150 Ecoboost:
    https://www.f150ecoboost.net/forum/6...11-2014-a.html
    https://www.f150ecoboost.net/forum/6...ts-2015-a.html


    New Members, please read through this thread for all the Rules for .Net
    https://www.f150ecoboost.net/forum/3...uidelines.html


Page 1 of 2 12 LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Rear Defrost not working...
    By 1tufgt in forum F150 Ecoboost Electronics
    Replies: 6
    Last Post: 02-11-2019, 02:14 PM
  2. Rear Defrost
    By NFLD in forum F150 Ecoboost Electronics
    Replies: 33
    Last Post: 01-12-2019, 06:08 PM
  3. Rear Defrost not working
    By dpaquett in forum F150 Ecoboost Problems
    Replies: 9
    Last Post: 03-15-2018, 01:11 PM
  4. 2013 KR Rear Defrost
    By ross1147 in forum F150 Ecoboost Problems
    Replies: 15
    Last Post: 02-03-2018, 08:16 PM
  5. Airbag Light, traction control, Hazard lights, & rear defrost all quit
    By ScottyB351w in forum F150 Ecoboost Problems
    Replies: 2
    Last Post: 03-15-2017, 04:41 PM

Search tags for this page

201 f150 mirror heater not working

,

2013 f150 defroster light not working

,

2014 f150 rear defrost fuse locations

,

f-150 mirror defrost

,

f-150 rear defrost mirror problems

,

f150 rear defrost doesnt light up

,

news

,

rear defroster and heated mirrors not working 2013 f150

Click on a term to search for related topics.
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+