Turbo leaking oil and making "Owl hooting" noise coming off boost. - Page 8

Turbo leaking oil and making "Owl hooting" noise coming off boost.

This is a discussion on Turbo leaking oil and making "Owl hooting" noise coming off boost. within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; Update: I dropped the pan and checked the torque of the bolts. They all seemed fine. I replaced about 7 quarts of fluid and added ...

Page 8 of 8 FirstFirst ... 678
Results 71 to 77 of 77
Like Tree21Likes

Thread: Turbo leaking oil and making "Owl hooting" noise coming off boost.

  1. #71
    Ecoboost Veteran TCP2's Avatar

    Join Date
    Jun 2017
    Location
    AB
    Posts
    336
    Member #
    36866
    Liked
    152 times
    Update:
    I dropped the pan and checked the torque of the bolts. They all seemed fine. I replaced about 7 quarts of fluid and added the dorman transmission pan with the drain bolt. The noise is still there, so my plan in the last post didn't change anything with the noise. Fresh fluid never hurts though.

    https://www.amazon.ca/Dorman-265-854...72923836&psc=1

    Name:  Capture.JPG
Views: 51
Size:  48.4 KB
    snakebitten likes this.
    -2016 XLT (XTR) 3.5 ecoboost supercrew 6.5' box, max tow, line-x, Bakflip MX4, Firestone ride-rite airbags, Vantech Rack, Alpine PWE-S8 Sub.
    -2019 Open Range UT2504BH.

    -Sold: 2009 XLT (XTR pkg) supercrew 5.4l 6sp 6.5ft bed. 131k miles, Rider Topper, Ride Rite airbags, Ford well liners, 5Star custom Tune.
    -Sold: 2010 Funfinder 189FDS
    -Sold: 2005 R-Vision Bantam Flyer F18 Hybrid

  2. #72
    Ecoboost Sr Member Calg_Rider's Avatar

    Join Date
    Feb 2014
    Posts
    52
    Member #
    3770
    Liked
    9 times
    So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
    2013 Ruby Red FX4 Ecoboost 5.5 box Crew with Max Tow Package

  3. #73
    Ecoboost Sr Member Calg_Rider's Avatar

    Join Date
    Feb 2014
    Posts
    52
    Member #
    3770
    Liked
    9 times
    So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
    Quote Originally Posted by Blown F-150 View Post
    I just get at them from the top-side. It's only loosening off the jam nut and the two nuts that mount the WG to the bracket.

    If you were pulling the liners for other reasons, it would for sure be easier from the side.
    2013 Ruby Red FX4 Ecoboost 5.5 box Crew with Max Tow Package

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #74
    Gold Supporting Member Blown F-150's Avatar
    Gold Member

    Join Date
    Feb 2016
    Location
    Calgary AB
    Posts
    1,925
    Member #
    15073
    Liked
    1101 times
    Quote Originally Posted by Calg_Rider View Post
    So still have this issue nagging at me. Before spending the cash on the new parts I was thinking I would reset the preload on the factory wastegates. Did you try that before replacing? If so did you go 2 or 3 turns?
    3 turns according to my Ford tech buddy

    I see that Full race now sells OEM replacement Wastegates, pretty awesome if you ask me.

  6. #75
    Ecoboost Master Envious's Avatar

    Join Date
    Dec 2015
    Location
    Colorado
    Posts
    1,206
    Member #
    14405
    Liked
    446 times
    Quote Originally Posted by Blown F-150 View Post
    3 turns according to my Ford tech buddy

    I see that Full race now sells OEM replacement Wastegates, pretty awesome if you ask me.
    Thanks for that! Just told @Calg_Rider there was no oem WGs
    2013 FX4 - Black Betty
    Boostking Tuned

  7. #76
    Gold Supporting Member Blown F-150's Avatar
    Gold Member

    Join Date
    Feb 2016
    Location
    Calgary AB
    Posts
    1,925
    Member #
    15073
    Liked
    1101 times
    Quote Originally Posted by Envious View Post
    Thanks for that! Just told @Calg_Rider there was no oem WGs
    I just saw them on the site a couple weeks ago. Pretty nice to finally have the option.


    Sent from my iPhone using Tapatalk
    Envious likes this.

  8. #77
    Rookie JF258's Avatar

    Join Date
    Jul 2019
    Posts
    1
    Member #
    72266
    Did resetting the factory preload fix your problem?

    I replaced drivers side turbo and this started as well. I did the timing chain and phasers. No change with the noise coming from turbo. Hoping someone has had some luck in finding a fix. Seems like it is talked about a lot but then the conversation just ends with no answer.

Page 8 of 8 FirstFirst ... 678

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Replies: 5
    Last Post: 03-01-2018, 08:33 AM
  2. Replies: 1
    Last Post: 02-14-2018, 07:49 AM
  3. Replies: 1
    Last Post: 01-10-2018, 04:34 PM
  4. Please look/listen - exhaust leaking water and chatter noise?
    By FiremanDan in forum F150 Ecoboost Problems
    Replies: 8
    Last Post: 02-04-2016, 05:55 PM
  5. Explorer Sport EcoBoost Turbos making weird noise LOSS of power
    By xsport in forum F150 Ecoboost Problems
    Replies: 10
    Last Post: 10-06-2014, 12:51 PM
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+