2013 F150 Ecoboost surging - Page 2

2013 F150 Ecoboost surging

This is a discussion on 2013 F150 Ecoboost surging within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; Oil leak between engine and transmission, could that be another sign?...

Page 2 of 2 FirstFirst 12
Results 11 to 16 of 16
Like Tree4Likes

Thread: 2013 F150 Ecoboost surging

  1. #11
    Gold Supporting Member Vrooom's Avatar
    Gold Member

    Join Date
    Apr 2019
    Posts
    14
    Member #
    71098
    Oil leak between engine and transmission, could that be another sign?

  2. #12
    Rookie 14 King's Avatar

    Join Date
    Jul 2018
    Posts
    9
    Member #
    66044
    Liked
    1 times
    Quote Originally Posted by Vrooom View Post
    Oil leak between engine and transmission, could that be another sign?
    I have the oil leak between my engine and transmission. I believe it is fairly common. It does not leave a mark on my garage floor or cause the oil level to go down. I think it is only leaking under acceleration/boost when moving. Read up on other threads to find out more info. I check my oil level regularly. If it starts to go down, or leaves a spot on my garage floor, I will get it fixed.

    If you have transmission fluid leaking out of the same spot, might be a transmission problem (torque converter?).

    Name:  IMG_20190203_201120800.jpg
Views: 80
Size:  1.39 MB
    snakebitten likes this.

  3. #13
    Ecoboost Pro Mikedick77's Avatar

    Join Date
    Apr 2018
    Location
    Wisconsin
    Posts
    512
    Member #
    59921
    Liked
    127 times
    Quote Originally Posted by Vrooom View Post
    Oil leak between engine and transmission, could that be another sign?
    I'd figure out how bad, and what fluid is leaking from that. Not certain this will point to your issue, but clues are clues. If you already suspect a torque converter, this leak is in the area. I'm not familiar with transmissions, so I wont speculate on this. But I do like to eliminate variables and follow the clues when i'm looking for a root of a problem. This may have to be the route you take for this. You're off to a good start.
    2013 Eco XTR 4x4 Super Crew 5.5 bed 3:31 Rear
    Stock, Weep hole, 160 degree T-Stat, Autolite Iridium XP5863 gapped properly, Castrol Magnatec 5w-30, and 93 octane
    NO OIL LEAKS!!

    Purrs like a kitten! It's called maintenence. This shouldn't surprise people.

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #14
    Eco-Beast noodles's Avatar

    Join Date
    Oct 2013
    Location
    Ontario, Canada
    Posts
    3,898
    Member #
    2745
    Liked
    1738 times
    Quote Originally Posted by 14 King View Post
    I have the oil leak between my engine and transmission. I believe it is fairly common. It does not leave a mark on my garage floor or cause the oil level to go down. I think it is only leaking under acceleration/boost when moving. Read up on other threads to find out more info. I check my oil level regularly. If it starts to go down, or leaves a spot on my garage floor, I will get it fixed.

    If you have transmission fluid leaking out of the same spot, might be a transmission problem (torque converter?).

    Name:  IMG_20190203_201120800.jpg
Views: 80
Size:  1.39 MB
    I'm guessing your rear main seal is leaking. Keep an eye on it, as it won't get better over time, and it looks like it's more than just weeping.
    Mikedick77 likes this.
    13 SuperCrew Ruby Red 302A, 4x4 6.5 box, 3.31, Roush 22's. Twin catch cans, "leveled" with Bilsteins (-2 front, -3 rear), AirLift, SCT. Other's may have displacement on demand... I have an endless supply of torque at my right foot's demand.


  6. #15
    Rookie Kimosan's Avatar

    Join Date
    Sep 2018
    Location
    Utah
    Posts
    5
    Member #
    67516
    Vrooom, did you ever solve your surging issue? I have a 2012 Platinum w/ 105k miles that is doing the same thing. I've replaced plugs, coils, cleaned map sensors, replaced throttle body, drilled weep hole, completed all SBs and the damned surge won't go away.
    2012 F-150 Platinum 3.5L Ecoboost

  7. #16
    Gold Supporting Member Vrooom's Avatar
    Gold Member

    Join Date
    Apr 2019
    Posts
    14
    Member #
    71098
    no, planning on doing it soon, but im pretty sure and 100 percent convinced it's my torque converter.

    Quote Originally Posted by Kimosan View Post
    Vrooom, did you ever solve your surging issue? I have a 2012 Platinum w/ 105k miles that is doing the same thing. I've replaced plugs, coils, cleaned map sensors, replaced throttle body, drilled weep hole, completed all SBs and the damned surge won't go away.

Page 2 of 2 FirstFirst 12

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. 2012 f150 surging
    By f150ecoboost in forum F150 Ecoboost Problems
    Replies: 4
    Last Post: 01-20-2019, 06:00 AM
  2. 2012 F150 Ecoboost Turbo surging
    By Chacemullin in forum F150 Ecoboost Problems
    Replies: 5
    Last Post: 01-08-2019, 09:00 AM
  3. 2013 3.5 surging and MPG issues
    By mreed1080 in forum F150 Ecoboost Problems
    Replies: 17
    Last Post: 09-20-2018, 04:42 PM
  4. 2011 F150, occasional boost 'flutter' / surging.
    By pfbz in forum F150 Ecoboost Performance
    Replies: 7
    Last Post: 12-02-2017, 06:10 AM
  5. 2012 F150 ecoboost surging during acceleration
    By JST4FN in forum F150 Ecoboost Problems
    Replies: 16
    Last Post: 08-31-2016, 11:53 PM
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+