Rough Idle on stopping, normal engine op driving

Rough Idle on stopping, normal engine op driving

This is a discussion on Rough Idle on stopping, normal engine op driving within the F150 Ecoboost Problems forums, part of the F150 Ecoboost Forum category; All, First off thanks for a solid forum here. Haven't posted a lot and I have been doing more lurking than writing but I have ...

Page 1 of 13 12311 ... LastLast
Results 1 to 10 of 125
Like Tree16Likes

Thread: Rough Idle on stopping, normal engine op driving

  1. #1
    Ecoboost Jr Member mooneywa's Avatar

    Join Date
    Jul 2014
    Location
    Texas
    Posts
    21
    Member #
    5805
    Liked
    6 times

    Rough Idle on stopping, normal engine op driving

    All,

    First off thanks for a solid forum here. Haven't posted a lot and I have been doing more lurking than writing but I have a bit of an issue:

    I have a 13 Eco with no engine mods and just shy of 36k miles. Upon stopping I get a rough idle, almost a shudder, for a little bit and then it goes away. It seems almost as if the engine is bogging down on stopping and then picks the rpm back up and it goes away. Sometimes it's worse than others but it's usually always there. It does it once the engine is warmed up, this isn't a cold-start rough idle. It does not throw a CEL. Shifting into neutral seems to diminish the rough idle by 80% or so.

    I took it into my local dealer and they took a look at it. This is a solid mx dept. and they are knowledgable and usually helpful. They kept the truck for over a week and 1) they felt the rough idle right away and 2) ran a ton of tests on it that Ford engineering directed. They came away with no cause or solution for the issue. Ford had them compare to a new model as well (yep, it idled rougher than a new model). Since nothing was "out of spec per throwing a CEL or other failed test" Ford said of course: it's normal. Dealer and I both agree it's not normal, but there's nothing either of us can do.

    Things I have done myself: check spark plug gap (in spec), bought new spark plugs, checked gap, reinstalled, double check all connections, check air filter. No fix.

    Thoughts on what this could be? Any ideas on a solution? Most searches turn up a cold weather rough idle or a constant rough idle which it isn't.

    Thanks guys!
    yox1923 likes this.

  2. #2
    Eco-Beast winchested's Avatar

    Join Date
    Aug 2013
    Location
    Southern Ontario, Canada
    Posts
    6,536
    Member #
    2128
    Liked
    2612 times
    Do a KAM reset and go through the idle re-learn process.

  3. #3
    Ecoboost Veteran Trailboss's Avatar

    Join Date
    Dec 2013
    Location
    West Lafayette IN
    Posts
    262
    Member #
    3143
    Liked
    205 times
    I had this going on, plus a really heavy thunk about 30 seconds after stopping at a light. Dealer re-flashed the trans and have never seen the issue since (about a year and a half)
    IF you plan on keeping your truck, SAVE YOUR ENGINE... USE A FULL SYNTHETIC OIL!
    Engine: Amsoil ASL 5W-30 Engine Oil.[/URL] Oil Filter: Amsoil BMK-23 Dual Remote Bypass system. Transmission: Amsoil ATL Transmission Fluid. Transfer Case: Amsoil ATF Transmission Fluid. Front Diff: Amsoil SVT 75W-110 Gear Lube. Rear Diff: Amsoil SVO 75W-140 Gear Lube.

  4. Remove Advertisements
    F150EcoBoost.net
    Advertisements
     

  5. #4
    Ecoboost Veteran Srlaubach's Avatar

    Join Date
    Sep 2014
    Location
    NE Pennsylvania
    Posts
    311
    Member #
    6325
    Liked
    87 times
    Quote Originally Posted by winchested View Post
    Do a KAM reset and go through the idle re-learn process.
    Winch, please elaborate on the KAM reset as to what it is and how it's done. Thanks in advance
    Tunnel_Vision likes this.

    2017 Raptor Magnetic

  6. #5
    Eco-Beast winchested's Avatar

    Join Date
    Aug 2013
    Location
    Southern Ontario, Canada
    Posts
    6,536
    Member #
    2128
    Liked
    2612 times
    Either unhook the battery for 30+ minutes and touch positive to negeative wire terminals together or turn head lights on after battery is disconnected to remove residual energy.

  7. #6
    Ecoboost Veteran Trailboss's Avatar

    Join Date
    Dec 2013
    Location
    West Lafayette IN
    Posts
    262
    Member #
    3143
    Liked
    205 times
    To be more specific, unhook the ground cable from the battery (cover the terminal with a rag or something to make sure the nothing touches it) and then jumper from that cable to the positive terminal for a few minutes. DO NOT touch the two battery terminals together. Ford Makuloco has a good video here:
    Last edited by Trailboss; 02-01-2015 at 11:32 AM.
    yox1923 likes this.
    IF you plan on keeping your truck, SAVE YOUR ENGINE... USE A FULL SYNTHETIC OIL!
    Engine: Amsoil ASL 5W-30 Engine Oil.[/URL] Oil Filter: Amsoil BMK-23 Dual Remote Bypass system. Transmission: Amsoil ATL Transmission Fluid. Transfer Case: Amsoil ATF Transmission Fluid. Front Diff: Amsoil SVT 75W-110 Gear Lube. Rear Diff: Amsoil SVO 75W-140 Gear Lube.

  8. #7
    Eco-Beast winchested's Avatar

    Join Date
    Aug 2013
    Location
    Southern Ontario, Canada
    Posts
    6,536
    Member #
    2128
    Liked
    2612 times
    Yes that is a better explanation haha. Not the battery but the wiring itself.

  9. #8
    Ecoboost Jr Member mooneywa's Avatar

    Join Date
    Jul 2014
    Location
    Texas
    Posts
    21
    Member #
    5805
    Liked
    6 times
    Quote Originally Posted by winchested View Post
    Do a KAM reset and go through the idle re-learn process.
    Winchested - Thanks for the help. I did this and it has cleaned up the idle significantly. Still a little rough on occasion but big improvement and doesn't feel like the truck is going to stall. Does the idle learn keep learning and if so for how long, or indefinitely? And what might have caused this to drop so low in the first place?

    Thanks guys!

  10. #9
    Eco-Beast winchested's Avatar

    Join Date
    Aug 2013
    Location
    Southern Ontario, Canada
    Posts
    6,536
    Member #
    2128
    Liked
    2612 times
    Did you go through the the process.

    1) Start and let idle until warm
    2)with e brake on and foot on brake put into D and idle for minimum 60 seconds
    3)Turn AC/ Heater on Max and redo the 60 seconds again.

    And yes it is always re learning, it is adaptive.

  11. #10
    Eco-Beast norcal_ecoscrew's Avatar

    Join Date
    Feb 2014
    Location
    KTCY
    Posts
    2,791
    Member #
    3814
    Liked
    1738 times
    ^^^ Yes to all the above, although I would also note that you should start the re-learn from a cold start, and let it idle all the way to warm up.
    2012 XLT SuperCrew Ecoboost 4x4, 3.31 Rear, 5.5 Box, Ingot Silver Metallic
    -Fox 2.0 Coilovers, Icon UCA's, Billstein 5100 Rears, Roadmaster Active Suspension
    -Falken Wildpeak AT3W 285/70R17, Pro-Comp 7032 17x9 -6 Offset
    -SCT x4 w/ Custom 91 Tune, S&B CAI w/ Dry Filter, Wagner CAC, Turbosmart BPV's, Full Race Catch Can, Solo Catted Downpipes, 3" custom catback
    -DeeZee Tailgate Assist, Husky Liners, Raptor Tans Mount, Silverstar Ultra Bulbs,
    F150Ecoboost.net Decal

Page 1 of 13 12311 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Similar Threads

  1. Rough idle on cold start.
    By BLOWBYU in forum F150 Ecoboost Problems
    Replies: 59
    Last Post: 07-08-2016, 01:51 PM
  2. If you have rough idle check this first
    By Talley in forum F150 Ecoboost Performance
    Replies: 15
    Last Post: 01-07-2016, 08:23 PM
  3. Slight Rough idle
    By Pwing in forum F150 Ecoboost Problems
    Replies: 26
    Last Post: 12-31-2014, 03:45 PM
  4. Engine noise. Normal??
    By Sunshine state in forum F150 Ecoboost Problems
    Replies: 15
    Last Post: 09-02-2014, 09:11 AM
  5. Is this Normal?
    By NorthTexas in forum F150 Ecoboost Problems
    Replies: 11
    Last Post: 03-06-2014, 09:12 AM

Search tags for this page

2012 ford f 150 ecoboost rough idle
,
2015 f150 ecoboost rough idle
,

2015 f150 rough idle

,
ecoboost f150 rough idle
,

f150 ecoboost missing at idle

,
f150 ecoboost rough idle
,
ford f150 rough idle and stalling
,
what causes rough idke ecoboost
Click on a term to search for related topics.
Connect with us: F150 Ecoboost Forum on Twitter F150 Ecoboost Forum on Facebook F150 Ecoboost Forum RSS Feed
Find us on Google+