F150 Ecoboost Forum banner
loss of power
1-5 of 6 Results
  1. F150 Ecoboost Problems
    Hello, I’m brand new to the forum so take it easy on me lol. I have a 2011 f150 fx4. I noticed a misfire at moderate acceleration so I picked up some new plugs and while installing them I snapped a vacuum line off the wastegate regulating sensor on top of the intake. So I replaced the part and...
  2. F150 Ecoboost Problems
    I know there are probably a few threads about this but I’m going to go ahead and ask it again. What are the best spark plugs you can use in your opinion, for a stock 3.5 V6 ECOBOOST
  3. F150 Ecoboost Problems
    Guess it's my turn.... Never a good thing if you have to post a thread in this section, is it? ;) Passenger turbo. Makes a noise like a ball bearing rattling around in a casted hollow aluminum part... Seems an easy diagnosis (I have a Ford tech friend coming to confirm this today), how hard is...
  4. F150 Ecoboost Problems
    I've been experiencing an intermittent loss-of-power/acceleration issue for about 4 months now. The problem is apparent, if not obvious, at low speeds, but really shows at highway speeds. A normal amount of pedal doesn't result in much of any acceleration. I need to push it up to ~ 4000+ RPM...
  5. F150 Ecoboost Problems
    I have had my ecoboost for about a month now, I have noticed on 2 lane roads if I pull out to pass a car and really get down on it, that the traction control light comes on and it kind of loses power for a second, but then picks back up, I wouldn't think it would be trying to spin the wheels at...
1-5 of 6 Results
Top