F150 Ecoboost Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
47 Posts
Discussion Starter · #1 ·
Yes it's pretty straightforward.

So I've had a intermittent problem.. Works sometimes....doesn't work others.
I have added a Forward camera that has always worked.
I played with unpluging and repluging and it would work for a while. So finally I threatened it....
Bought a OEM Camera. pt # FL3Z-19G490-D The original was pt # FL3T-19G490-AG

The new camera works......Well sorta.....It is missing the Zoom and the trailer ball dotted line.
You can push the X on the screen for the zoom and hear a beep, but does nothing.

Do I have the wrong camera? I've had it a while in the tool box waiting for the original to do a total fail. So no sending it back and @ almost $300.....OUCH!

Does it need a software update? I have never done that "Health" thing that pops up once in a while.. I just never registed to do it.
Truck has 45K mi. on it now I special ordered this truck.

Any help is appropriated. :)
 

·
Registered
2018 STX 2.7 CAI, Resi Delete, SCT X4, 2" drop shackles, 305/45/22, RF Jams, RC covers, Tint LED's !
Joined
·
12 Posts
I bought a 2018 STX with a non working camera at the 1st of the year and I really had a hard time making sure I had the correct cam myself so I picked up a used one off flea bay for less than 20 bucks shipped, that way if it was wrong it did not hurt so bad. Turned out to match the cam I had and works flawlessly for months now. I did unplug the harness, checking it and the pins while doing so. Good Luck.
 

·
Registered
Joined
·
47 Posts
Discussion Starter · #3 ·
Vintage.......Does yours have the X on the screen to zoom.....and also show the dotted line trail to the Ball of the hitch?
 
1 - 3 of 3 Posts
Top