F150 Ecoboost Forum banner

1 - 20 of 32 Posts

·
Registered
Joined
·
26 Posts
Discussion Starter #1
I have a 2011 F150 FX4 Ecoboost with an issue the dealership has not been able to solve so I’m looking for help. I’ve searched through threads and not found one with all the same symptoms in the forums.
After taking a trip for 30 minutes or more then stopping for 20 minutes or so the pickup will start then go into a rough idle and ultimately stall. It has a long crank time to restart like a no fuel situation. Originally this would be the end of it and it would run normally at restart. Now it may exhibit the issue 3-5 times before it runs normally. The dealership diagnosed it as a HPFP the first time but it did not solve the issue. Since then they can not explain it or they say it did not act up for them. It has started to stall now when allowed to idle for extended period of time when already warm. I haven't videod it myself but the video below is exhibiting the same symptoms but mine is more severe.



 

·
Registered
Joined
·
26 Posts
Discussion Starter #2
Damn...got a pile of people looking but no one has any words of wisdom or ideas for me? It’s early yet, hopefully someone has some good ideas. I’ll check back tomorrow.
 

·
Premium Member
Joined
·
1,108 Posts
I've got nothing for you sorry.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #5
Thanks for nothing bespurcell...lol just kidding. I know it’s a complicated issue. If it was simple I wouldn’t have to ask. I love everything about the pickup but this one issue!

I noticed that I had left that out slothman...
It does not generate any codes when it stalls. The plugs have been changed out and gapped to .030 with no change in the issues it presents. I believe I put in the 534 plug but would have to pull one or find my old invoice to be absolutely sure. I haven’t found any vacuum leaks and I would really hope the dealership looked for that when it was in.
 

·
Registered
Joined
·
3,937 Posts
Damn...got a pile of people looking but no one has any words of wisdom or ideas for me? It’s early yet, hopefully someone has some good ideas. I’ll check back tomorrow.
Could be a bad check valve on the in-tank fuel pump, allowing fuel to drain back when you shut it off.
Next time it happens, prime the fuel system 3 times. On the 4th cycle start the truck.
Unless it's some electrical gremlin, I wouldn't think it should be too hard to figure out.
 

·
Registered
Joined
·
3,937 Posts
honestly it could be a hundred different things. you need to drive it until a CEL shows.
That's what a Ford adviser would say. No codes, no worky.
 

·
Registered
Joined
·
951 Posts
honestly it could be a hundred different things. you need to drive it until a CEL shows.
That's what a Ford adviser would say. No codes, no worky.

How is the guy supposed to keep driving on this?. And your telling him to keep driving till the CEL shows, but what if it never shows? I’m calling BS.

Take it to another auto clinic if you have to . Hope your trucks feeling better soon .


2012 screw 3.5L
 

·
Registered
Joined
·
26 Posts
Discussion Starter #12
Bad part is that I have been driving it trying to get it to fail or finally throw a code but that’s obviously not working but getting worse with time
 

·
Registered
Joined
·
9 Posts
I was wondering if this is the same as my problem. I drive it like 30 miles and then let it sit for maybe 20-30 minutes and restart it. Idles really rough when I restart it and has little power. If I can finally get it to rev up then the problem goes away. I been getting low fuel pressure codes on mine recently. I took it to a shop but they couldn't find anything wrong with the fuel system when they check the pressures. They gave up and said I should take it to a dealer.
 

·
Registered
Joined
·
26 Posts
Discussion Starter #14
I was wondering if this is the same as my problem. I drive it like 30 miles and then let it sit for maybe 20-30 minutes and restart it. Idles really rough when I restart it and has little power. If I can finally get it to rev up then the problem goes away. I been getting low fuel pressure codes on mine recently. I took it to a shop but they couldn't find anything wrong with the fuel system when they check the pressures. They gave up and said I should take it to a dealer.
Sounds very similar! If you let it go and not try to rev it up will it stall? If so I’d say it’s the same. If not it might be the same thing just at the early stages. I’ve been trying to solve this for well over a year. It has become worse with time but whatever is causing it will not fail completely. I believe it is something with a certain part thermo cycling but haven’t been able to track it down yet!!!
 

·
Registered
Joined
·
26 Posts
Discussion Starter #15
I’m hoping to find some time to work on it again this weekend and see if I can get any new data or clues. Bad thing is that it takes about an hour for each cycle so it’s not a fast process. Going to start with a fresh slate and change out plugs with fresh ones again to absolutely rule that out. May even change out the battery beings I have a spare from a work truck. Fresh clean spark and pretty fresh steady voltage and start rechecking everything from there. I will have my phone ready to take video and my diagnostic computer hooked up reading live data.
 

·
Premium Member
Joined
·
3,219 Posts
If you guys do plugs, make sure to use stock motor craft gapped to .028-.030 (feeler gauge) and replace the spark plug boots.
 

·
Registered
Joined
·
9 Posts
Sounds very similar! If you let it go and not try to rev it up will it stall? If so I’d say it’s the same. If not it might be the same thing just at the early stages. I’ve been trying to solve this for well over a year. It has become worse with time but whatever is causing it will not fail completely. I believe it is something with a certain part thermo cycling but haven’t been able to track it down yet!!!
It dies (if that is the same thing as stalls) every once in a while, but not all the time. It mainly just will sit there idling rough and not have any power and won't hardly rev up. If it dies then it does take a long time to start up again. I also changed out my spark plugs not long ago so I doubt that is my issue.

You said you had the HPFP changed out and that didn't fix it?
 

·
Registered
Joined
·
26 Posts
Discussion Starter #18
It dies (if that is the same thing as stalls) every once in a while, but not all the time. It mainly just will sit there idling rough and not have any power and won't hardly rev up. If it dies then it does take a long time to start up again. I also changed out my spark plugs not long ago so I doubt that is my issue.

You said you had the HPFP changed out and that didn't fix it?
Yes, my dealership said it was a fuel pressure issue and with this fuel setup the pressure is regulated by the HPFP so I had them replace it and it is still doing the same thing and getting worse over time.
 

·
Registered
Joined
·
3,937 Posts
Yes, my dealership said it was a fuel pressure issue and with this fuel setup the pressure is regulated by the HPFP so I had them replace it and it is still doing the same thing and getting worse over time.
Have you tried priming the system prior to start up?
 

·
Registered
Joined
·
671 Posts
It does sound like a fuel issue.

However, maybe the throttle body itself. I have seen lots of issues with them, some with and some without codes.
 
1 - 20 of 32 Posts
Top