F150 Ecoboost Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
15 Posts
Discussion Starter #1
Been fight this issue for about a month issue comes and goes showing more and more here lately so here we go:

When I get into any kind of boost the timing will go to like -14 to -20 advanced spark 1 on my sct ts+ will get up to the 16xxx range truck has 84xxx miles no check engine lights no loud motor noises boost will climb up into the 18-19lb range truck will struggle to get out of its on way Avg like 8-9 miles per gallon motorcraft plugs gapped to .030 cleaned the mass airflow sensor and replaced map sensor truck is tuned by 5 star took it to them last week they looked at it replaced the throttle body still not fixed tested gas always ran 93 premium

Mods: AFe stage 2 (dry) CAI, AFE catless downpipes, 3.73 gears, AFE bladerunner charge pipe, AFE Mach Force XP 4in catback, Turbosmart kompact blow off valve, 1/16 hole drilled in the intercooler
 

·
Registered
2013 Ford F150 XLT 3.5 Ecobeast SuperCrew 4X4
Joined
·
1,338 Posts
Stretched timing chains ?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #3
I’ve did a lot of reading on that and I don’t think so it don’t rattle on start up and it’s pretty intermittent seems as if I let the truck sit a couple days it will be fine then up back couple hours after driving taking it to another ford dealership today and see if they can figure it out he said they work on performance stuff all the time so will see
 

·
Registered
Joined
·
5,139 Posts
Been fight this issue for about a month issue comes and goes showing more and more here lately so here we go:

When I get into any kind of boost the timing will go to like -14 to -20 advanced spark 1 on my sct ts+ will get up to the 16xxx range truck has 84xxx miles no check engine lights no loud motor noises boost will climb up into the 18-19lb range truck will struggle to get out of its on way Avg like 8-9 miles per gallon motorcraft plugs gapped to .030 cleaned the mass airflow sensor and replaced map sensor truck is tuned by 5 star took it to them last week they looked at it replaced the throttle body still not fixed tested gas always ran 93 premium

Mods: AFe stage 2 (dry) CAI, AFE catless downpipes, 3.73 gears, AFE bladerunner charge pipe, AFE Mach Force XP 4in catback, Turbosmart kompact blow off valve, 1/16 hole drilled in the intercooler
I think the spark advance you are quoting is the TOTAL Spark Advance. And in certain situations, you can indeed see large negative Total Spark Advance.

What is your KR and OAR readings?

Those are the items you wish to monitor, not total spark advance.

BTW, what year of truck and engine?
 
  • Like
Reactions: SrpRacing

·
Registered
Joined
·
15 Posts
Discussion Starter #5
Not really sure my sct won’t show the knock unfortunately what is the OAR? My afrs on bank 1 and 2 are going down into the 8-9s
 

·
Premium Member
Joined
·
569 Posts
You need to set up a new config that has all the correct PIDs. Contact 5* and they will get you set up.

The timing you speak of is Intake VVT not Spark advance. VVT is always negative.

Grim is right. Spark Advance 1 is TOTAL Spark.


What tune? That would help.
 

·
Registered
Joined
·
15 Posts
Discussion Starter #7
It sat at 5 star for a week and half they couldn’t figure it out just got it back from them Thursday they put a new throttle body on it 93 perf tune on the truck currently
 

·
Registered
Joined
·
15 Posts
Discussion Starter #8
3 ford dealerships and 5 star tuning and they still can’t tell me what is wrong with my truck the cam phasers and timing chain all have been checked said they almost look brand new no play or anything told me my fuel trims on my programmer are wrong and ford is saying the tune is bad 5 star is saying tune is good ford said the tune is telling the truck to dump 15% more fuel then what it’s calling for 🤦🏼‍♂️ So I’m back to square one of not know what is wrong with my truck
 

·
Registered
Joined
·
15 Posts
Discussion Starter #10
Yep same issue gonna get it from dealership tomorrow gonna put new plugs and pull bov and check the diaphragms possible bov is popping and air not make it to the cylinder?
 

·
Registered
Joined
·
15 Posts
Discussion Starter #11
So I pulled the plug today new plugs gapped at 0.028 the plugs smelled like gas took and drove the truck rolling black smoke out the exhaust so now I’m assuming it’s a high fuel issue afrs on bank 1&2 going to like 7-9 boost will be at 18-20lbs of boost and sparking going to -20 fuel mileage is at like 8-9 miles per gallon
 

·
Registered
Joined
·
15 Posts
Discussion Starter #12
Also put the stock tune back on it it ran good for 20-30 miles and start doing it again on the stock tune
 

·
Premium Member
Joined
·
569 Posts
PM me and I’ll get you set up with a proper config to load. Very confusing when you say you’re seeing -20 spark.....
 
1 - 13 of 13 Posts
Top