F150 Ecoboost Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have a 2012 F150 Ecoboost with 12,000 miles and about 2 weeks ago I started to get a engine noise. The noise sounds like when you hear a vehicle that's brakes are shot and you have metal on metal grinding / rubbing when you apply the brakes, if that makes sense. The noise usually lasts for about 5 seconds. I took the air cleaner cover off because that is where the sound is coming from the loudest. I am quite certain it is one of the turbos but usually only does it a start up, although I did hear it once after I had stopped the truck and was backing up. Wondering If anyone else had this problem and what It was. Thanks
 

·
Registered
Joined
·
3,883 Posts
Yeah I freaked over turbo noise, on colder days it sounds like the truck is getting ready to head into orbit for the first few minutes of idle..... Never a metal on metal noise though, kinda lame to ask, but are you keeping up with your oil level?
 

·
Vendor
Joined
·
1,173 Posts
Any of the tensioner or idler pulley's can make a similar sound if the bearings are going also, and that would be an easy fix. Have someone listen at the engine bay when it's started and try to pin-point just where it is coming from. Ford service center will be able to as well
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
I took the air cleaner box cover off, its definitely a noise coming from down by the turbos. Oil levels are good, just changed about a month ago. Since only 12K miles on it, it will be going to the shop for warranty work. If it is the tubos, it won't sit well with me that one went so soon.
 

·
Registered
Joined
·
1,028 Posts
I have a 2012 F150 Ecoboost with 12,000 miles and about 2 weeks ago I started to get a engine noise. The noise sounds like when you hear a vehicle that's brakes are shot and you have metal on metal grinding / rubbing when you apply the brakes, if that makes sense. The noise usually lasts for about 5 seconds. I took the air cleaner cover off because that is where the sound is coming from the loudest. I am quite certain it is one of the turbos but usually only does it a start up, although I did hear it once after I had stopped the truck and was backing up. Wondering If anyone else had this problem and what It was. Thanks
brberno,

It certainly wouldn't hurt to have the dealer take a look. Send me a PM with your name, phone number, VIN, mileage, and dealer info. I'll lend a hand.

Ashley
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
Ashly, It is scheduled for Tuesday. I also have them checking out two other problems I'm having. One is the "Shudder" when towing a load, seems to be a problem that Ford don't have a solution for on the SuperCrews with the 6.5' box. Second is the display for Miles to Empty that fluctuates back and forth or wont move at all for many miles at a time. Thanks for the heads up on help, if it don't get the proper attention at my dealership next week, I'll let you know. Ben
 

·
Registered
Joined
·
1,028 Posts
Ashly, It is scheduled for Tuesday. I also have them checking out two other problems I'm having. One is the "Shudder" when towing a load, seems to be a problem that Ford don't have a solution for on the SuperCrews with the 6.5' box. Second is the display for Miles to Empty that fluctuates back and forth or wont move at all for many miles at a time. Thanks for the heads up on help, if it don't get the proper attention at my dealership next week, I'll let you know. Ben
Sounds like a plan, Ben. Just let me know!

Ashley
 

·
Registered
Joined
·
5 Posts
Discussion Starter #9
Truck is in the shop today. They couldn't find the turbo noise until I called and told them to open the hood and listen when it starts because it only lasts 5 - 8 seconds. They then heard it and now have a call in to Ford Tech I guess to try and find what it may be since they don't know....go figure. Second thing is the shudder I have from a dead stop when pulling my travel trailer. They didn't know what I was talking about there either, I spelled it out that its all over the forums as either axle wrap or driveline shudder on the Supercrew Ecoboost with 6.5 box. They said they did a transmission update dia update. Hmmmm don't think that will fix the problem. Won't even bring up the instrumentation problem that its also in there for. Lots of problems on a $46.000 truck and not even 12,000 miles on it yet.
 

·
Registered
Joined
·
108 Posts
Any news on this? I just started getting a Wierd noise on start up. Approaching 37k miles so I may be screwed if it's pricey. My noise is also only a few seconds after start up and is very loud.
 
1 - 10 of 10 Posts
Top