F150 Ecoboost Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Hey everyone. I just purchased a new F150 Ecoboost Platinum a few weeks ago. I picked up a SCT tuner from MPT. I have been trying to flash the off the shelf tunes from the SCT tuner in my truck but it keeps erroring out with 1017 upload stock failed. I contacted SCT tech support and they had me check some things, and they said pin 13 on the connected should have 18 volts when checked, but the truck doesn't even have a pin in that location? Does anyone have any insight into this or run into this problem?
 

·
Registered
Joined
·
523 Posts
What connector are you referencing? The ALDL connector under the driver side kick panel where the tuner plugs in?

Do you have a diagram for the pin out of the connector you reference. I nor most owners have any idea what pin location is designed 13. Thus with the information supplied we can't go check our trucks to provide you any feedback.
 

·
Registered
Joined
·
9,640 Posts
Here's the pin out on mine. '13 FX4, and no issues hooking up a tuner.
Might see if yours has pins in the same locations.



View attachment 2818
 

·
Registered
Joined
·
868 Posts
wow, i have had some issues in the past where a few wires were pinned in diff locations due to model change and it makes for a rough time correcting it
if your not familiar with changing the pin configurations on that OBDII port i would seriously recommend not touching it
one wire in the wrong place there and you will have a real bad day not to mention a dead truck

this is your typical configuration and i dont know what has changed that would be using pin 13 for power instead of pin 16 but im wondering if you actually have an OBDIII now
untitled.png
Pin 2 - J1850 Bus+
Pin 4 - Chassis Ground
Pin 5 - Signal Ground
Pin 6 - CAN High (J-2284)
Pin 7 - ISO 9141-2 K Line
Pin 10 - J1850 Bus
Pin 14 - CAN Low (J-2284)
Pin 15 - ISO 9141-2 L Line
Pin 16 - Battery Power
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
scap99 - my connector looks the same. I don't believe it is an issue with the connector now as I tested it on my friend's 11 HD 6.2 and it flashed it right away with no problems. Perhaps my ECU is not supported yet? What tuner are you using?
 

·
Registered
Joined
·
523 Posts
Can the tuner communicate and interact at all with your truck? In the Vehicle Info menu can you read Vehicle Info or Read DTC's?
 

·
Registered
Joined
·
9,640 Posts
scap99 - my connector looks the same. I don't believe it is an issue with the connector now as i tested it on my friend's 11 hd 6.2 and it flashed it right away with no problems. Perhaps my ecu is not supported yet? What tuner are you using?
sct sf3
 

·
Registered
Joined
·
3 Posts
Discussion Starter · #9 ·
Got the issue fixed with SCT support. The issue was that they no longer use pin 13 to flash the ECU in the F150's. When the tuner gets connected, it attempts to read the ECU to unlock the binary code. I was told that if it doesn't do this just right, the tuner will not be able to flash the ECU. David at SCT sent me a "custom tune" of what my stock tune is, which was then loaded onto the programmer. Once this was done, it "unlocked" the tuner and ECU and I was able to flash the ECU.
 
1 - 9 of 9 Posts
Top