F150 Ecoboost Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 · (Edited)
Hey folks - this is my first time posting here and looking for some help. 56 days ago I bought a "Ford Certified" F150 from a dealership in Glendale, AZ. Since I have had the truck in my possession it has been in the shop for a total of 19 days. A bulk of the time was spent replacing the Timing chain, Tensionors and Cam phasers. I got the truck back from this repair on July 26 and returned the vehicle to the dealership on Monday July 31st because it now has a knocking/dieseling sound at idle. It has been at the dealership since and they don't seem to know what the issue is. Any ideas?

Truck has 45,000 miles on it.

Here are a couple short video's to hear the sound....


 

·
Registered
Joined
·
5,973 Posts
Hard to tell man, I'm sure most are going to say it sounds normal, really though audio through a video and not in person isn't the best way to diagnose something like this. I hear a few things in your videos, one being the high pressure fuel pump...


2013 F 150 ecoboost 4x4 xlt crew cab
34/10.5/17 KO2's
Bilstiens front leveling coil overs top setting
3" autospring rear blocks
And some other crap

Sent from my iPhone using Craptalk
 

·
Premium Member
Joined
·
4,079 Posts
The only thing I hear is the High Pressure Fuel Pump. They are LOUD to people who aren't used to them. ;)
 
  • Like
Reactions: RMB_Ryan

·
Registered
Joined
·
3 Posts
Discussion Starter · #5 ·
Just posting an update to this thread. Well it looks as if one of the tensioners that was replaced was defective, so the dealership swapped it out. They also had to replace the instrumentation panel on my dashboard because it was reading incorrect RPM's and sending false info the the trucks system causing the AC to turn off.

I have had the truck back now a week and it seems to be running alright. I have noticed a drastic drop in MPG. I was averaging about 17mpg (combined) before both timing chain replacements. I have driven a combined 280 miles and am averaging around 13 MPG. I have also noticed that the electric fans that cool the motor are significantly louder than before.

Cause for concern?

Thanks for your input so far.
 
1 - 5 of 5 Posts
Top