F150 Ecoboost Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
I have a 2013 xlt ecoboost. Last night I thought maybe I accidentally tirned the knob to ON instead of auto and left my lights on (and Ibmay have), battery died, I jumped ect....
Today when I left the house I first noticed that my cruise control wasnt working, radio control wasnt working, dash dimmer wasnt working. So for those are the only issues that showed while driving. When I go home I double checked the light switch before locking up and the lights will not turn off.

Any ideas why, has anyone had this issue before? Fuses, relays anything that connects all of these?

Thanks in advance.
Adam B.
 

·
Registered
Joined
·
17 Posts
disconnect the battery and wait 10 minutes and reconnect to reset the bcm. Is the first thing you should try. The BCM/smart junction box controls all these
 

·
Registered
Joined
·
17 Posts
It was disconnected all night
Same outcome? do you have anything plugged into the obdII ? all those systems including the the radio communicate via CAN sometimes a programmer can wreak havoc when flashing the ecm Obviously I would check every single fuse with a multimeter and ensure they are good. The junction box controls every thing they do fail you can google F150 smart junction box failures and see if your symptoms match any of what others have dealt with. I've only replaced the sjb once since 2011 and that vehicle was flooded and twice had to send the customers to ford and have them diagnose and reflash the sjb. But they were honestly due to no start no crank issues
 
1 - 5 of 5 Posts
Top