F150 Ecoboost Forum banner

1 - 20 of 24 Posts

·
Registered
Joined
·
12 Posts
Discussion Starter #1
Hello All,

Brand new to the EB community and this forum! We just purchased a new to us 2011 EB XLT SuperCrew 4x4 Off Road with 1:3.73 locker rear end at the end of April. It pulls our 31' Airstream very nicely!

Currently working on the small things that needed attention (lube driveshaft, leaky brake light, etc.) but this one has me stumped. Hoping someone here can help. When I shift into 4x4, I can hear the solenoid engange and I can confirm that it is actually throwing the transfer case into gear by driving and also jacking up the front and checking front wheel spin. Oddly, the little LCD screen between the gages (message center?) does not show that it is in 4x4 mode, or 4 low, or anything. One of our local Ford dealers simply stated that perhaps it was not an option for the XLT. I'm not buying it.

Does anybody else have this problem and if so, pointers on where to start?

Thanks! John
 

·
Registered
Joined
·
3,474 Posts
I'm not sure on the 4x4 problem that you are having, but which brake light is leaking?
Just make sure you don't refill it with blinker fluid. The seals are not compatible.
 

·
Registered
Joined
·
3,474 Posts
OP, I don't have much on the 4x4 light issue, but I know on my Jeep there is a linear potentiometer that is depressed a certain distance based on what position the T-case is in. As the voltage changes, the BCM will detect the change and will turn on/off the lights on the dash. If this potentiometer gets out of whack, the incorrect light can be on, or none at all, even if the t-case is actually engaged in 4x4.

I would imagine that they would have some kind of positive engagement sensor like that, so it doesn't say its in 4x4 when its not.
 

·
Registered
Joined
·
1,841 Posts
I have an 2013 XLT and it has a 4x4 indicator.
I had a highway patrol physically look at the dash to let me through a chain up area without chains. Guess he didn’t believe it was a 4x4.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #7
OP, I don't have much on the 4x4 light issue, but I know on my Jeep there is a linear potentiometer that is depressed a certain distance based on what position the T-case is in. As the voltage changes, the BCM will detect the change and will turn on/off the lights on the dash. If this potentiometer gets out of whack, the incorrect light can be on, or none at all, even if the t-case is actually engaged in 4x4.

I would imagine that they would have some kind of positive engagement sensor like that, so it doesn't say its in 4x4 when its not.
I've looked under that thing ad nauseam and scoured the Haynes manual and internet for clues to some sort of switch or something like that. There is an eBay listing for some sort of switch, but no idea where it may go on this thing! I agree that it does not appear something is getting some sort of signal. And yes, I do realize that this is a bit OCD. Oh well.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #8
OP, I don't have much on the 4x4 light issue, but I know on my Jeep there is a linear potentiometer that is depressed a certain distance based on what position the T-case is in. As the voltage changes, the BCM will detect the change and will turn on/off the lights on the dash. If this potentiometer gets out of whack, the incorrect light can be on, or none at all, even if the t-case is actually engaged in 4x4.

I would imagine that they would have some kind of positive engagement sensor like that, so it doesn't say its in 4x4 when its not.
So new thought: Does anybody have a lead on a good and thorough electrical schematic for the 4x4 system? I have a hunch there is some sort of wiring issue on the connector of the motor, if it was replaced by the previous owner. The Haynes manual is disturbingly lean on the electrical stuffs!
 

·
Administrator
Joined
·
7,787 Posts
The third brake light on the cab.

This has been a known issue with the cab corners rusting. Make sure all the moisture is out of the whole cab corner and rear roof area before reinstalling and sealing your light.
 

·
Registered
Joined
·
16 Posts
I also have a 2011 4x4 in XLT trim with 3.73 rear (limited slip in my case). I can confirm that it definitely should show a message during the change (“4x4 shift in progress” and when going to 4x4 low the screen will prompt you to shift to neutral) then after the change it will illuminate with 4x4 or 4x2 right next to the odometer.

Also, after initial key-on without even starting the truck it will momentarily illuminate the 4x2 on the display right after the bulb test (abs, tpms, airbag, parking brake, etc).

Do you get either the 4x4 shift in progress message when engaging 4x4 or the momentary 4x2 indication on initial key-on?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #13
I also have a 2011 4x4 in XLT trim with 3.73 rear (limited slip in my case). I can confirm that it definitely should show a message during the change (“4x4 shift in progress” and when going to 4x4 low the screen will prompt you to shift to neutral) then after the change it will illuminate with 4x4 or 4x2 right next to the odometer.

Also, after initial key-on without even starting the truck it will momentarily illuminate the 4x2 on the display right after the bulb test (abs, tpms, airbag, parking brake, etc).

Do you get either the 4x4 shift in progress message when engaging 4x4 or the momentary 4x2 indication on initial key-on?
Thank you very much! So, we know that I am not losing my mind or crazy! I do receive any message whatsoever with key on or changing into 4x4 or back. I'm really thinking a wiring issue at the connector to the solenoid motor or near there. Also could be a fuse like an earlier poster suggested. I'll be taking a look soon.
 

·
Registered
Joined
·
3,474 Posts
Thank you very much! So, we know that I am not losing my mind or crazy! I do receive any message whatsoever with key on or changing into 4x4 or back. I'm really thinking a wiring issue at the connector to the solenoid motor or near there. Also could be a fuse like an earlier poster suggested. I'll be taking a look soon.
You ever consider that maybe a dealer F'd up a flash and turned off the 4x4 **** in the IPC(the computer that controls the instrument cluster)? Like if your truck didn't come with a brake controller then those features are not enabled but are already baked into the computer software. When you add your own brake controller later, the dealer can just go in an enable the brake controller features in the instrument cluster and it works just like it came from the factory.

The same issue might be happening with the 4x4. Maybe the clusters features are turned off for some reason and it is set to 2wd or something, and it's otherwise functioning but just not showing up on the dash.

You could use software called Forscan to go in an check. It basically has the same functionality of the dealer and can go in and read from the dash computer and make changes.
 

·
Registered
Joined
·
3,474 Posts
If you lock your diff in 2wd does that show up?
 

·
Registered
Joined
·
12 Posts
Discussion Starter #16
You ever consider that maybe a dealer F'd up a flash and turned off the 4x4 **** in the IPC(the computer that controls the instrument cluster)? Like if your truck didn't come with a brake controller then those features are not enabled but are already baked into the computer software. When you add your own brake controller later, the dealer can just go in an enable the brake controller features in the instrument cluster and it works just like it came from the factory.

The same issue might be happening with the 4x4. Maybe the clusters features are turned off for some reason and it is set to 2wd or something, and it's otherwise functioning but just not showing up on the dash.

You could use software called Forscan to go in an check. It basically has the same functionality of the dealer and can go in and read from the dash computer and make changes.
Hmm. I'd have to check that out! I've heard of the Forscan - I'll have to try that out soon. Thanks!
 

·
Registered
Joined
·
12 Posts
Discussion Starter #18
I also have a 2011 4x4 in XLT trim with 3.73 rear (limited slip in my case). I can confirm that it definitely should show a message during the change (“4x4 shift in progress” and when going to 4x4 low the screen will prompt you to shift to neutral) then after the change it will illuminate with 4x4 or 4x2 right next to the odometer.

Also, after initial key-on without even starting the truck it will momentarily illuminate the 4x2 on the display right after the bulb test (abs, tpms, airbag, parking brake, etc).

Do you get either the 4x4 shift in progress message when engaging 4x4 or the momentary 4x2 indication on initial key-on?
There is no indication whatsoever on the screen from 4x2 to 4x4 to 4x4 Low or locked differential. Ugh.
 

·
Registered
Joined
·
3,474 Posts
No, it does not. Tried that also. I'll also have to check the fuses as well, but I'm not holding out hope on that one!
Huh. Well unless there is something funky with the switch itself, i cant imagine how the two systems would overlap and both not work.

I would get in Forscan and see if they set the drive to 2wd without ELD.

https://docs.google.com/spreadsheets/d/15MQ8CEh7eSXUJYjPg-J8uUqpLwP_xyqbfQHB0rAnXNs

If you go under the IPC tab on that sheet then you will see the address and options for the 4x4 settings a little ways down. This is what you would look for in Forscan.
 

·
Registered
Joined
·
12 Posts
Discussion Starter #20
Huh. Well unless there is something funky with the switch itself, i cant imagine how the two systems would overlap and both not work.

I would get in Forscan and see if they set the drive to 2wd without ELD.

https://docs.google.com/spreadsheets/d/15MQ8CEh7eSXUJYjPg-J8uUqpLwP_xyqbfQHB0rAnXNs

If you go under the IPC tab on that sheet then you will see the address and options for the 4x4 settings a little ways down. This is what you would look for in Forscan.
Thank you very much!!! I found the area on the spreadsheet. I also downloaded the 'lite' version for my Android phone - most likely need the paid version to look at this, but I'll try.
 
1 - 20 of 24 Posts
Top