F150 Ecoboost Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
40 Posts
Discussion Starter #1
Hi everyone new to the ecoboost forum, hoping someone can give me an answer. I put a Afe cold air intAke stage 2 dual filters on my 2012 ecoboost fx4 super crew. I definentally feel a slight increase in power and acceleration despite what people say about CAI's. But at low RPMs I hear a clunking sound if i press on and off on the pedal quick. I didn't notice it with the stock system. There is a slight bend at the end of one of the pipes where it meets the filter, but i made it work and it seems like everything is sealed good. Check it every other time i get home from work everything is tight still and it sounds good. Just wondering if anyone's experienced the same sound or if anyone knows what the weird low rpm clunking is. Sounds like it's definentally from the engine bay, not a drive shaft sound. Thanks guys
 

·
Registered
Joined
·
223 Posts
loosen all the clamps and see if you can take some of the tension out of the couplers. also make sure the lid is firmly snapped in place
 

·
Registered
Joined
·
1,502 Posts
My airaid intake did the same thing. I noticed no difference using it over my drop in, so I just use the drop in filter now.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #5
Ok, so just loosen the clamps up to relieve so much tension. Tighten them back up but not to to tight?
 

·
Registered
Joined
·
223 Posts
the AFE clips into the bottom of the factory airbox, mad sure that is secure.

what i did was start at the filter box and work my way to the piping
 

·
Registered
Joined
·
40 Posts
Discussion Starter #7
The Afe box is secure to the factory air box, I loosend everything up, re clamped it starting from the filters. Took a test drive can barely hear the clunk sound. So I think Its better. It almost blended in with the blow off so maybe it's good now. That was just from a quick neighborhood drive. on my way to work tomorow I'll really be able to tell. If I hear it the same, I'll call a local shop and see if they can re Instal it for me for a low cost. Thanks again for the advice and quick reply
 

·
Registered
Joined
·
40 Posts
Discussion Starter #8
Drove to work today. Still hearing the noise under hard acceleration and letting almost off the pedal but still applied and I'll hear it. I'm probably getting a near by shop to check on it. I'm not too good with cars, but the intake was simple enough. I guess I'll see if a shop can fix my issue. If it's not the intake and somthing else I'll switch back to my stock intake and bring her in
 

·
Registered
Joined
·
7,313 Posts
Probably hearing your blow of valves recirc.
 

·
Registered
Joined
·
40 Posts
Discussion Starter #11
ITs really hard to determine what it is, Itll build up and blow off normal but louder then stock and mellows out nice. But It makes a sound I can't put my finger on. I've tryed re clamping it down. Loosened the clamps and checked everything and I'm definentally good. Sealed off good. Clamped down tight, doesn't seem like there's to much tension. When I press the gas pedal I hear a thunk sound. If I press it rapidly it will do it.. press pedal lightly , thunk let off, press lightly again thunk so on so on
 
1 - 11 of 11 Posts
Top