F150 Ecoboost Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
339 Posts
Discussion Starter · #1 ·
The reason I ask is I just heard the "plugs" are different on the 2013 and it is no longer plug and play. I wanted to find out if any 2013 owners have installed the Recon or any other brand for that matter and did you have any problems with fitting into the plugs on the 2013 model. I am told from a semireliable source that you now have to rewire directly.
 

·
Registered
Joined
·
2,630 Posts
Maybe send Recon an email and ask? I was thinking about ordering some.


Sent from my iPhone using Tapatalk 2
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #4 ·
Maybe send Recon an email and ask? I was thinking about ordering some.


Sent from my iPhone using Tapatalk 2

I did and they were super nice but without pictures they can not really do much. My neighbor has this problem and had to direct wire all the lights. He saved the connections from Recon and I will try to take a pic and send to them. I just hoped someone with a 2013 had done an install by now. Sure would save some time to know for sure. ANYONE>>>>>>>>>>>>>>>>>>>>>>>
 

·
Registered
Joined
·
100 Posts
I have the recon tails on my 2013 Limited. It was a direct plug in. The thing is, the socket the factory bulb is plugged into has to be removed. It is a plastic socket that is clipped on. A flathead can release the clip so the socket can be removed. I will post a pic of the socket once I get home. Here is a pic of the tails on my truck. ImageUploadedByTapatalk 21375579158.445515.jpg
 

·
Registered
Joined
·
339 Posts
Discussion Starter · #9 ·
Post pics when you're done! I'm assuming by your user name you have a limited. Post even more pics of that too!
Will do. I am out of town but once back I will try to get some pics done. My Limited is black. I planned to get Ruby Red but once I saw that black I was hooked. Never owned a black vehicle but this black color is really stunning.
 
1 - 9 of 9 Posts
Top