F150 Ecoboost Forum banner

1 - 20 of 21 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter · #1 ·
I have a new to me 2012 xlt with a towing package.

I have the basic sync so no screen.

I have rearview mirror that has the lcd built in.

When I go into reverse the lcd goes blue for a few seconds. After researching it I thought maybe the camera was bad. So I go to look and I don’t have a camera at all. Didn’t see a plug for one either. Might be there but hiding. I’d like to have a backup camera though and would like it to be oem style.

Do you think if I purchase the camera and find the plug will it work and show up in the rear view mirror? I don’t want to buy it and be sol.
 

·
Modinstrator
Joined
·
3,179 Posts
To my knowledge Ford never put the back up screen in the mirror. That’s aftermarket stuff I believe.
 

·
Registered
Joined
·
578 Posts
I had one in my 2011 in the rearview mirror.

I had a camera in the tailgate.

Mine went blue several times ... each time the camera was replaced under warranty
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #6 ·
I had one in my 2011 in the rearview mirror.

I had a camera in the tailgate.

Mine went blue several times ... each time the camera was replaced under warranty
I checked all over the tailgate incase there was a different spot than what I’ve seen but I don’t have a camera.
 

·
Registered
Joined
·
19 Posts
My 2011 is in the rearview mirror.
You need a new camera. Once it's replaced you'll need to have it calibrated at the dealer or do it yourself with forscan.
 

·
Modinstrator
Joined
·
3,179 Posts
Well... sounds like that might be a problem.
 

·
Registered
2015 Lariat 4WD
Joined
·
140 Posts
Is it not on the leading edge (bottom) of your Ford emblem?
 

·
Registered
Joined
·
19 Posts
Looks like someone swapped out the emblem.
Open your tailgate and look at the space between the tailgate and the truck bed. Right in the middle, do you see a wire harness going from the tailgate into a hole leading underneath the truck bed?
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #16 ·
Looks like someone swapped out the emblem.
Open your tailgate and look at the space between the tailgate and the truck bed. Right in the middle, do you see a wire harness going from the tailgate into a hole leading underneath the truck bed?
There is a hole there but no wire. It may have fell down but can get my hand up there to find it.
 

·
Registered
2015 Lariat 4WD
Joined
·
140 Posts
Yes, I agree. My theory is that the previous owner for some reason removed the emblem, BUT Ford made those emblems one time use only because the tabs break so easily in them.

That was likely a much cheaper replacement then the factory with the camera.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
7,594 Posts
My 2011 is like that with it in the mirror and it isn't factory its an aftermarket camera and harness. I had to replace the harness/camera from the back to the front after it gave me the blue screen.

Cameras with harness are like $20 on amazon.

Mine is mounted at a 45 deg under the tailgate emblem.
 

·
Registered
Joined
·
3,883 Posts
My guess since it is a truck; something happened to tailgate. It was replaced for resale by the cheapest version available. Pretty common, really.
 

·
Registered
Joined
·
25 Posts
Discussion Starter · #20 ·
My guess since it is a truck; something happened to tailgate. It was replaced for resale by the cheapest version available. Pretty common, really.
I could see that. I do think it’s original though. This is also a factory rearview mirror with the dimming feature and the driver side mirror dimmer also. Tomorrow I will have time to find the plug and then decide on my next action.
 
1 - 20 of 21 Posts
Top