F150 Ecoboost Forum banner

21 - 40 of 42 Posts

·
Registered
Joined
·
5,569 Posts

·
Registered
Joined
·
282 Posts
I went to 5star AO tune and it works great. Very happy.
Awesome! 5* is the best IMO.

P.S. I knew it wasn't your truck, but I was trying to be nice..
 

·
Registered
Joined
·
471 Posts
I went to 5star AO tune and it works great. Very happy.
How are you liking the AOT? I run the BCB AOT's but grabbed a free 5* AOT with the free black friday offer. Do you have any other tunes to compare it to? This will be my first 5* tune.

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
425 Posts
I made the switch also from BCB to 5*star AO and all I can say is I should’ve done it sooner. Especially since the AO tune is tow safe makes it an even better tune. Good bump in power and great shifting. Almost like a Perf/tow tune made to adjust for different octanes. I stick to towing with the AO rather than going back to my dedicated octane perf/tows. Truck just drives phenomenal. You won’t be disappointed.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #26
How are you liking the AOT? I run the BCB AOT's but grabbed a free 5* AOT with the free black friday offer. Do you have any other tunes to compare it to? This will be my first 5* tune.

Sent from my SM-N960U using Tapatalk
Honestly I have only tried the BCB tune. They just couldn't get it to work with my truck for some reason. They said to change plugs to one step colder and .28 gap which i did, when their tune still didn't work they said I needed to change the coils which is about 400 bucks. I knew at that point I should try something new. Went to 5* and their AO has had no issues from the start. I have head of problems with the BCB tune maxing out the turbos and WG's being at 100%. I was was pushing about 21psi of boost with BCB and running into misfires and popping at the top end with a bad drop in power and the transmission not shifting out of gear. The 5* AO shifts great and I'm hitting about 18.5psi with much more power. Not bashing BCB by any means. Their tune just didn't work on my truck.
 

·
Registered
Joined
·
10 Posts
Discussion Starter #27
I made the switch also from BCB to 5*star AO and all I can say is I should’ve done it sooner. Especially since the AO tune is tow safe makes it an even better tune. Good bump in power and great shifting. Almost like a Perf/tow tune made to adjust for different octanes. I stick to towing with the AO rather than going back to my dedicated octane perf/tows. Truck just drives phenomenal. You won’t be disappointed.
I made the switch also from BCB to 5*star AO and all I can say is I should’ve done it sooner. Especially since the AO tune is tow safe makes it an even better tune. Good bump in power and great shifting. Almost like a Perf/tow tune made to adjust for different octanes. I stick to towing with the AO rather than going back to my dedicated octane perf/tows. Truck just drives phenomenal. You won’t be disappointed.
I am very happy with the AO. All perimeters that i monitor are good and the power is great. Never got the BCB tune to run correctly. I have lower safer boost pressure with more power.....and my transmission shifts gears now lol.
 

·
Registered
Joined
·
471 Posts
I made the switch also from BCB to 5*star AO and all I can say is I should’ve done it sooner. Especially since the AO tune is tow safe makes it an even better tune. Good bump in power and great shifting. Almost like a Perf/tow tune made to adjust for different octanes. I stick to towing with the AO rather than going back to my dedicated octane perf/tows. Truck just drives phenomenal. You won’t be disappointed.
I'm loading it up now, I tow a lot over here in AZ and am not a fan of switching back and forth. I've been running the mcgyver tune as a daily driver. I honestly haven't had any issues with either of the BCB AO tunes but would love the best of both worlds in just one!!

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
471 Posts
I'm only seeing 16ish of boost, is this normal for a 17 3.5 on 91 with this AO 5*tune?

Sent from my SM-N960U using Tapatalk
 

·
Registered
Joined
·
471 Posts
Honestly I have only tried the BCB tune. They just couldn't get it to work with my truck for some reason. They said to change plugs to one step colder and .28 gap which i did, when their tune still didn't work they said I needed to change the coils which is about 400 bucks. I knew at that point I should try something new. Went to 5* and their AO has had no issues from the start. I have head of problems with the BCB tune maxing out the turbos and WG's being at 100%. I was was pushing about 21psi of boost with BCB and running into misfires and popping at the top end with a bad drop in power and the transmission not shifting out of gear. The 5* AO shifts great and I'm hitting about 18.5psi with much more power. Not bashing BCB by any means. Their tune just didn't work on my truck.
Are you running 93 with AO 5* tune? I only have 91 in AZ and seeing 16ish of boost. Tune feels great though!

Sent from my SM-N960U using Tapatalk
 

·
Administrator
Joined
·
10,578 Posts
Honestly I have only tried the BCB tune. They just couldn't get it to work with my truck for some reason. They said to change plugs to one step colder and .28 gap which i did, when their tune still didn't work they said I needed to change the coils which is about 400 bucks. I knew at that point I should try something new. Went to 5* and their AO has had no issues from the start. I have head of problems with the BCB tune maxing out the turbos and WG's being at 100%. I was was pushing about 21psi of boost with BCB and running into misfires and popping at the top end with a bad drop in power and the transmission not shifting out of gear. The 5* AO shifts great and I'm hitting about 18.5psi with much more power. Not bashing BCB by any means. Their tune just didn't work on my truck.
I have had some small issues here and there with my truck through my tuning journey. I've learned that with many tuners, when they encounter some issues that stump them, they start blaming you or the truck. It's not just SSI. That's what I've loved about working with @Boostking . He encountered the same things but kept working with me and kept trying until we got great results and nice safe data.

Sent from my Moto Z3 Play using Tapatalk
 

·
Registered
Joined
·
10 Posts
Discussion Starter #33
Are you running 93 with AO 5* tune? I only have 91 in AZ and seeing 16ish of boost. Tune feels great though!

Sent from my SM-N960U using Tapatalk
I am seeing about 18.5 with the occasional spike at 19. I’m also at about 5500 feet above sea level so if I’m not mistaken I should be seeing a 1 to 2 psi more because of the thinner air. I could be wrong though.
 

·
Registered
Joined
·
32 Posts
Alright everyone, I've skimmed through the topic here and I've got similar concerns. With my 93 Perf tune, as well as the Highlander, after a WOT pull, whether its complete or partial, its like my transmission hangs and doesn't know to shift, or go into what I would call "overdrive," when I lift off the throttle. Im wondering if anyone else is having this issue, as well as, after running my 93 tune, its almost like my computer begins to unlearn the tune, or lose its spunk after a period of time. I've noticed this problem, even when I continue to buy fuel from the same exact location with consistent octane fuel chosen. Thanks in advance for your input!
 

·
Registered
Joined
·
282 Posts
Alright everyone, I've skimmed through the topic here and I've got similar concerns. With my 93 Perf tune, as well as the Highlander, after a WOT pull, whether its complete or partial, its like my transmission hangs and doesn't know to shift, or go into what I would call "overdrive," when I lift off the throttle. Im wondering if anyone else is having this issue, as well as, after running my 93 tune, its almost like my computer begins to unlearn the tune, or lose its spunk after a period of time. I've noticed this problem, even when I continue to buy fuel from the same exact location with consistent octane fuel chosen. Thanks in advance for your input!
Call 5*


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
282 Posts
Alright everyone, I've skimmed through the topic here and I've got similar concerns. With my 93 Perf tune, as well as the Highlander, after a WOT pull, whether its complete or partial, its like my transmission hangs and doesn't know to shift, or go into what I would call "overdrive," when I lift off the throttle. Im wondering if anyone else is having this issue, as well as, after running my 93 tune, its almost like my computer begins to unlearn the tune, or lose its spunk after a period of time. I've noticed this problem, even when I continue to buy fuel from the same exact location with consistent octane fuel chosen. Thanks in advance for your input!
If I was looking to find info on a problem I was having and found a thread discussing the exact problem I would do more than skim it. The other guy fixed his truck by changing tuners. BCB tried to blame the truck..The 5* tune fixed it. The end..


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: Sirikenewtron

·
Administrator
Joined
·
10,578 Posts
The first step is always to communicate with your tuner. They will likely request a data log, so do so, send it in, they should tweak the tune and send you a revision.

If they can't fix it, and it doesn't happen on the stock tune, next I usually try a different tuner. If the same issue occurs then I'd start investigating something up with on my end.

Sent from my Moto Z3 Play using Tapatalk
 

·
Registered
Joined
·
32 Posts
The reason i posted is due to inconsistencies and it isn’t easily duplicated on command while data logging. It’s unpleasant, and it hadnt been doing this from the beginning. I was asking to gain input from the people who have had problems, and to hear the details of what their EB was doing. It very well may end up being replaced by 5 Star.
 

·
Premium Member
Joined
·
6,788 Posts
Is this happening in Sport mode? If so that's normalish behavior.

Sent from my Moto Z3 Play using Tapatalk
I was going to say, after a WOT pull, when I let off the throttle, it does NOT immediately upshift and drop the rpms to normal.
Instead, it coasts down very similar to a manual transmission vehicle.



Sent from my SM-N950U using Tapatalk
 
21 - 40 of 42 Posts
Top