F150 Ecoboost Forum banner

1 - 20 of 41 Posts

·
Registered
Joined
·
114 Posts
the OEM SP-534 work just fine as that is what most guys are putting in and you can find them at Oreilly for like $3.99 a plug
 

·
Registered
Joined
·
3,705 Posts
motorcraft sp534 plugs.jpg

Frankly SCAP probably knows which plug is best better than anyone. I just figure since the rest of my engine is stock, I am sticking to Motorcraft.
 
  • Like
Reactions: scap99

·
Registered
Joined
·
3,705 Posts
Mine has 12K on it. I have seen so many stories on here, I have been planning on finding time to re-gap mine for months. I just went ahead and bought new ones to swap out. Only cast 5.99 each at the stealership.
 

·
Registered
Joined
·
3,705 Posts
My truck only has 37000 miles. Is it normal to need to replace so early?
Is seems someone at the Ford factory was using the plugs to open beer. The reported gaps on stock trucks are pretty ridiculous.
 

·
Registered
Joined
·
608 Posts
Turbo vehicles eat plugs. They're pretty inexpensive to do yourself.

The best plugs are the ones you chose.
 
  • Like
Reactions: mc4100s2 and scap99

·
Administrator
Joined
·
7,857 Posts
Is it normal for ford spec to be .32 but when you pull the plugs they range from .35-42?


Btw mines a 2012 with 40,000kms


Sent from my white iPad 3 in a (RED) smart case using an app called Tapatalk
Here we go with the kms talk again.


hehe :cool:
 

·
Registered
Joined
·
440 Posts
Been thinking about buying a set of plugs for mine, upper rpms it has a slight stumble and power delivery isn't so smooth. Anybody going with a colder plug for the higher boost from the tunes? Or has any tuner notice a difference tuning with a colder plug?
 

·
Registered
Joined
·
9,641 Posts
Been thinking about buying a set of plugs for mine, upper rpms it has a slight stumble and power delivery isn't so smooth. Anybody going with a colder plug for the higher boost from the tunes? Or has any tuner notice a difference tuning with a colder plug?
Did you check/reset your gap before you loaded your tune?
 

·
Registered
Joined
·
440 Posts
Yea, gapped all mine at .028. Both mpt and let tune idle rough so I don't think it's a "bad" tune. Its not missing at idle, just a constant roughness, lol, like it has solid motor mounts. I have around 14k on the truck so I'm up in the air about the plugs.
 
1 - 20 of 41 Posts
Top