F150 Ecoboost Forum banner

61 - 80 of 101 Posts

·
Registered
Joined
·
3,912 Posts
I don't think the pics do justice, they look taller and nice. IMO
Tires look good on the truck, and should work well, but I can't stand trying to keep the white lettering white. I would've gone black side out... but that's my opinion.
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #62
Tires look good on the truck, and should work well, but I can't stand trying to keep the white lettering white. I would've gone black side out... but that's my opinion.
Yeah. Keeping that white white is tough. But its a cross I am happy to bear. I like the look. I am only in my 40's but its probably more old school, i know. The current trends are what you say. Most would agree with you. But I am sticking with all chrome too.

Wife likes it.... If Mamma ain't happy...
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #63
I wanted to say again, break in period on the tires! Probably was 800-1000 miles.

Got them rotated today, about 4k on them. The service guy and I were chatting and he mentioned break in was a couple hundred miles, people think they are under inflated.... Its more like 800-1000. But that is exactly what I was feeling.
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #64 (Edited)
Tired of wacking the garage door. Cut off the antenna. My truck still is at a rake. The roof is curved. I used the break light area as like a gun site to pick a spot on the wall. 77.5" or 6'5.5" is my best guess. Cut about 5" off antenna. So antenna height is now at 68" or 6'6".

Removed antenna, vice, sawsall. Grinder to smooth tip. Pulled ball off with two hammers. Claw on ball, and tapped with other. I used JB Weld, but i also ground a point, put it in a vice and tapped it on. I tried heat first, but that didn't work. JB on that little wire that tried to unravel a bit.

Haven't driven to know if reception is affected. This was free, I can always buy something, if so.

20161231_161857.jpg
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #65
20161209_071755.jpg I am happy with the tire. I can't believe how silly stock looks to me now.
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #66
For Christmas, wife said I have the "go ahead" for bilsteins and add-a-leaf.
Unfortunately, I pay the bills and need to wait to clear a few outstanding other things.... But soon!
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #67
On the antenna note. I cut mine. I live 45 minutes out of the city, and drive to the downtown city and back. All major stations, no change, all fine.

However, there is one small country radio station about 2 hours from the city. It was always a little staticy.
So now, after cut, in the city, the static is not worth tolerating. But 15 minutes into my drive home, its fine again.

So to recap, mostly no change, but if you have one or a couple stations that aren't that clear to begin with, there will be a slight decrease.
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #68
Truck was missing 90k. Put in new spark plugs this weekend. 20k on them. Much better, but I might have felt one miss today, fingers crossed I was wrong. Next try is coils.

Sent from my SM-N920P using Tapatalk
 

·
Registered
Joined
·
1,513 Posts
Removed antenna, vice, sawsall. Grinder to smooth tip. Pulled ball off with two hammers. Claw on ball, and tapped with other. I used JB Weld, but i also ground a point, put it in a vice and tapped it on. I tried heat first, but that didn't work. JB on that little wire that tried to unravel a bit.
Great suggestion, it just works, it's easy and it doesn't cost anything. I've done this for a couple of decades on probably a dozen trucks. I've have never noticed any decrease in reception. Funny that Ford doesn't stop to think about how high a garage door is. One suggestion is to just take a pair of electrical pliers (crimping circle) and put it behind the ball, you can also use a brake/hydraulic line flaring tool. The flaring tool works well because it is tapered to go around the ball, leaves no marks. Hold a rag behind the ball so you don't lose it. A couple of taps and you will have the ball in your hand with no marks on it. As Coletrain mentioned grind the end of the antenna to a point being careful to not disturb the wire on the end. You can loosen this wire if not careful but can cut another inch off if that happens. A little epoxy and a quick mist of spray paint and you'll never notice that it was touched.
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #71
Put in 6 new coils. It was missing even on stock. FYI i used a pick to pull out my broken red clips. Worked great!
Not sure if problem fixed, but new coils in. Motorcraft on Amazon seemed the best value. $50 each. There were cheaper, but not much, so I went with Motorcraft.

After doing it, i noticed more spring in the new ones. Maybe only the boots needed changed. Oh well, we did it all.


Sent from my SM-N920P using Tapatalk
 

·
Registered
Joined
·
1,840 Posts
My truck is missing horribly so I can't even drive it. Contemplating changing the coils to see if it solved it. Broke four connectors changing plugs because I was in an extreme hurry and pop them off with pliers since I forgot the grey tabs need depressed also. Dumbest move ever but it hasn't ran right since and only gotten worse.


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #73
My truck is missing horribly so I can't even drive it. Contemplating changing the coils to see if it solved it. Broke four connectors changing plugs because I was in an extreme hurry and pop them off with pliers since I forgot the grey tabs need depressed also. Dumbest move ever but it hasn't ran right since and only gotten worse.


Sent from my iPhone using Tapatalk
Ouch. I am a dummy too sometimes. My mechanic buddy says he has held them on with zip ties. I dont know your specific situation, but I am not hearing from you the coils are the problem. Maybe buy a couple, that are broken the most.
I hope i fixed my issue. It was popping like popcorn on my e30 tune, and still on stock.

Sent from my SM-N920P using Tapatalk
 

·
Registered
Joined
·
1,840 Posts
Ouch. I am a dummy too sometimes. My mechanic buddy says he has held them on with zip ties. I dont know your specific situation, but I am not hearing from you the coils are the problem. Maybe buy a couple, that are broken the most.
I hope i fixed my issue. It was popping like popcorn on my e30 tune, and still on stock.

Sent from my SM-N920P using Tapatalk
Already replaced the connectors with brand new OEM ones. They are actually pretty easy to replace, just expensive. So I believe it's either a wiring issue or a coil issue


Sent from my iPhone using Tapatalk
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #76
Already replaced the connectors with brand new OEM ones. They are actually pretty easy to replace, just expensive. So I believe it's either a wiring issue or a coil issue


Sent from my iPhone using Tapatalk
The boots are $5 on amazon. Motorcraft coils $50. Might want to just try the boots. I just went for it.

Sent from my SM-N920P using Tapatalk
 

·
Premium Member
Joined
·
2,088 Posts
Also, if you do coils/boots/plugs, always put some di-electric Grease inside the plug boots. Not a lot, but a little will help spark going in a direction it shouldn't.
 

·
Administrator
Joined
·
4,073 Posts
Also, if you do coils/boots/plugs, always put some di-electric Grease inside the plug boots. Not a lot, but a little will help spark going in a direction it shouldn't.
And do a KAM reset!
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #79
#1. WE ARE OVER 100,000 MILES

#2. New battery, something is killing my batteries, I got credit from AZ for the last battery and threw more money at it. Optima yellow.

#3. Got led lights for christmas. My brother got me the turn signals, and it went to hyperflash and I didnt want to mess with those resisters.
So in the end, I got reverse lights and fog lights.
*** Reverse lights were really my main target, with tinted windows, I couldnt see anything when I back up at night. I had to roll down my window.
my review is, now I can see something with the LED's. Its not 1 million candlepower, but it is better. Next might have to be adding additional lights. But I may not, these LED's may help me get by.


Sent from my SM-N920P using Tapatalk
 

·
Registered
Joined
·
2,196 Posts
Discussion Starter #80
Led reverse lights

Regarding the LED BULBS.
the front ones don't do any good, they are brighter, don't misunderstand, but the fog lights don't assist much when driving, compared to all the headlight power.
The taillights are a LOT brighter. I was trying to see in reverse with tinted windows at night. I went from "cant really see at all" to "I can see something" I want to make clear, the lights do their job, just understand it's a little light, don't expect a led bar worth of light.
 
61 - 80 of 101 Posts
About this Discussion
100 Replies
15 Participants
coletrain
F150 Ecoboost Forum
F150Ecoboost.net is the best Ford F150 Ecoboost Forum with discussions on 2011+ F150 Ecoboost Trucks. Discuss performance mods, towing questions, wheels, tires, lift kits, and much more!
Full Forum Listing
Top