F150 Ecoboost Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
2,315 Posts
Discussion Starter #1
I am sure will find it with research, but the light on the switch comes on, just no heat at the buutocks.......

Ideas.

I guess i can check the fuse, the wires under the seat.....outside of that, I guess it goes in for warranty then?
 

·
Registered
Joined
·
175 Posts
That's too new for heaters to be inop. If not anything easy, have dealer fix. I just found a bulb out on tail light, toyed with the idea of bringing it in....

I don't have that much time to waste, LOL
Hope it a quick fix for you... still 90 degrees here:(
 

·
Registered
Joined
·
2,315 Posts
Discussion Starter #3
That's too new for heaters to be inop. If not anything easy, have dealer fix. I just found a bulb out on tail light, toyed with the idea of bringing it in....

I don't have that much time to waste, LOL
Hope it a quick fix for you... still 90 degrees here:(
90 degree's here too, just getting ready for the colder weather!!!
 
  • Like
Reactions: Arkansas Eco

·
Registered
2013 Ford F150 XLT 3.5 Ecobeast SuperCrew 4X4
Joined
·
1,646 Posts
Ya I bought a gallon of the winter wiper lube today in anticipation.
 
  • Like
Reactions: TOWMA8R

·
Registered
Joined
·
5,641 Posts
Arent the heated and cooled seats ran of a fan or something? YEs i realized the pads are inside the seat but I think the stuff under the seat plays into it too. There is a company that makes a aftermarket fix for the seats as the ford design is bad....check into that
 

·
Registered
Joined
·
2,315 Posts
Discussion Starter #6
Arent the heated and cooled seats ran of a fan or something? YEs i realized the pads are inside the seat but I think the stuff under the seat plays into it too. There is a company that makes a aftermarket fix for the seats as the ford design is bad....check into that
I'll take aa loo. I have not started researching yet
 

·
Registered
Joined
·
5,704 Posts
No fans of you just have heated, as I do, and not cooled too


Sent from my iPhone using Tapatalk
 
  • Like
Reactions: TOWMA8R

·
Registered
Joined
·
2 Posts
I am sure will find it with research, but the light on the switch comes on, just no heat at the buutocks.......

Ideas.

I guess i can check the fuse, the wires under the seat.....outside of that, I guess it goes in for warranty then?
 
1 - 8 of 8 Posts
Top