F150 Ecoboost Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter · #1 ·
Hey guys long time listener first time caller. So my truck started loosing power like gearing down to 4th on a slight slope and the CEL came on and I got the dreaded P0016 code. Was loosing sleep hoping it wouldn't be the code but here we are.

I have a couple of questions. I live on the Sea to Sky corridor in BC and I'm sure some have you have seen the current conditions and state of emergency that has been going on here due to the weather. My problem is I need the truck to commute and the conditions are bad as I drive in the snow to get to work I don't fancy my girlfriends minivan as the truck is safer. I can't get the truck in for a couple of weeks to get the work done would it be safe to still use it?

It's strange as it drove fine today no issues at all it comes and goes. My next question is it recently had an oil change if those guys put wrong oil in would it cause this issue? As it's so up and down the last few weeks ran like a rocket one day then dead the next. Surely if it was the chain would it not be dead all the time?

Thank you for any help and advice. I'm pretty gutted as this has come at a bad time for me.
 

·
Premium Member
2013 XLT 302A 145" Screw
Joined
·
4,043 Posts
Year model of pickup and engine ? How many miles on it ?
 

·
Registered
Joined
·
1,278 Posts
Could be...hard to say. I mean, straight 50 weight in the cold might hah. Have you tried the pre oil starting procedure? Floor it and turn the key until you see oil pressure on the gauge.
 
1 - 7 of 7 Posts
Top