F150 Ecoboost Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
97 Posts
Discussion Starter #1
Had engine light come on this morning, DTC code po12d came up on sct live wire ts. I was able to clear it but I turned truck off and then turned it back on, engine light came back on. Returned truck to stock the light us gone. I have had the tuner set on canned 93 perf tune. No other issues. Any input will be appreciated.
 

·
Registered
Joined
·
838 Posts
Had engine light come on this morning, DTC code po12d came up on sct live wire ts. I was able to clear it but I turned truck off and then turned it back on, engine light came back on. Returned truck to stock the light us gone. I have had the tuner set on canned 93 perf tune. No other issues. Any input will be appreciated.
Had same code. Ford replaced the map sensor. Not tune related.
 

·
Registered
Joined
·
838 Posts
Thank you for input.
no problem. It was an issue with map voltage. Stayed at 4.1 volts no matter what. They changed it and the voltage changed accordingly. Havent had an issue in 5,000 miles.
 

·
Registered
Joined
·
97 Posts
Discussion Starter #5
I dropped off truck a dealership for replacement returned truck to stock. Let's see what they do and how long it's there for. I still haven't got around to installing the afe Stage 2 I wonder if they would do the install for me...
 

·
Registered
Joined
·
97 Posts
Discussion Starter #6
Well the dealership said there is a "short" In the wire harness that goes to one of the turbos. They are going to replace the harness. They scanned the CPU and said everything was normal. FYI I have been using SCT livewire 93 performance tune. All will be covered by warranty truck only has 16k miles
 

·
Registered
Joined
·
838 Posts
Well the dealership said there is a "short" In the wire harness that goes to one of the turbos. They are going to replace the harness. They scanned the CPU and said everything was normal. FYI I have been using SCT livewire 93 performance tune. All will be covered by warranty truck only has 16k miles
WOOF!!! Mine was only the sensor
 

·
Registered
Joined
·
97 Posts
Discussion Starter #8
Truck is ready. I missed it let's see if anything else goes wrong with it. I'm the type of person that thinks that they will sabotage it to get me to go back...I hope I'm wrong.
 

·
Registered
Joined
·
1,028 Posts
Truck is ready. I missed it let's see if anything else goes wrong with it. I'm the type of person that thinks that they will sabotage it to get me to go back...I hope I'm wrong.
Web13,

My name is Ashley and I'm the new Ford Service rep here on the forum. Let me know how your dealer visit went. I'm happy to lend a hand if you need it.

Ashley
 

·
Registered
Joined
·
97 Posts
Discussion Starter #10
Very well actually. However...when I got my truck back my tuner SCT livewire would not recognize the vehicle I don't know if PCM was reflashed and I need to update the tuner on the website . I did return to stock prior to service.
 
1 - 10 of 10 Posts
Top