F150 Ecoboost Forum banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
A little background, I have a 2015 f150 with the 3.5 EB with just over 50k miles. Over the winter I started to have what I thought was the normal EB shutter I have read so much about. The truck would idle very rough at cold start and as it would come down from high idle the tach would bounce quite a bit. Even after warm at idle you could feel a slight shake and see the tach move. Changed the plugs thinking they were part of the problem happened at .03 but it made no difference. Took it into the dealer who said I had entire bank of injectors failed that would be replaced under warranty. Picked it up and it seemed fixed for about a week or two and now it’s back almost worse than it was before. It’s at the dealer now but I’m curious if anyone else has seen injector failure in this truck and what caused it or if anyone has had similar issues. Before taking it in this time I hooked it up to a scanner and the idle after warm looked like a heart rate monitor! It seemed to constantly bounce between 600 and 750 rpm regardless of AC on or off. The dealer said this is one of few injector failures they have seen on this motor and the first time they’ve replaced an entire bank like that.
 

·
Registered
Joined
·
242 Posts
People have had like 1 or 2 let go (like full on hydro lock motor go boom) but an entire bank? that does not sound like a normal eco issue
 
1 - 2 of 2 Posts
About this Discussion
1 Reply
2 Participants
BigPhatPaulie
F150 Ecoboost Forum
F150Ecoboost.net is the best Ford F150 Ecoboost Forum with discussions on 2011+ F150 Ecoboost Trucks. Discuss performance mods, towing questions, wheels, tires, lift kits, and much more!
Full Forum Listing
Top