F150 Ecoboost Forum banner
1 - 20 of 52 Posts

·
Registered
Joined
·
59 Posts
Discussion Starter · #1 ·
My truck has been acting up a bit over the last several months. Primarily it stutters/hesitates when accelerating and it feels identical to a misfire where the truck hangs up and then surges as you try and accelerate. Also, very rarely, when idling and at cruising speed the engine will have a little hiccup that again feels like a misfire. No codes have been thrown, ever. Changing drive modes also doesn't affect it, although it feels like it does it less when in sport mode. Certain tunes also make the "misfire" worse. I have been tuned for almost 10k kms running BCB MacGyver tune and very rarely felt the misfire except when under full throttle, but it would be almost not noticeable it was so small and light.

A month ago I returned the truck to stock to take it in for an oil change (1 week in advance to get some key strokes in) thats when I noticed the misfire more. After the oil change I returned to MacGyver and the hesitation all but when away, for the most part. then a week later I decided to try the Highlander tune and the hesitation was so bad that I couldn't even get up to highway speeds and each misfire shook the truck. I pulled over and returned truck to stock. That's where I've been since.

I then took it to my local Ford dealership and they had it for 2 days. During that time they said that they checked everything they could think of and had it hooked up to multiple computers trying to find the cause. It's stumped the shops foreman and he said that he's never seen anything like it. He, along with several others in the shop fully acknowledge that something is going on but no one can pinpoint what is causing it.

Has anyone here had any similar experiences or any clue as to what could be causing it?

Edit: Truck is a 19 Supercrew with 3.5 EB.
 

·
Banned
Joined
·
316 Posts
Have you pulled a plug? How many KM's? My first thought would be plugs.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #4 ·
I have pulled the plugs and checked gap. Everything was very clean and gapped at 0.28 on all but two that were 0.29. That shouldn't be enough of a gap to cause any issues.

Also I run 91 premium fuel only.
 

·
Premium Member
Joined
·
6,765 Posts
How many miles on plugs ?
 

·
Premium Member
2015 Ford F150 XL 2.7 Supercab
Joined
·
377 Posts
I had a similar issue with my old F-150; hesitation as you described, no codes, but definitely something wrong. To add to the frustration, it would only act up every so often. In my case, it turned out to be a bad coil. I found the problem by swapping the spark plugs one by one with a good one, and then doing the same with a good coil when the plugs checked out OK. I justified the expense of a spare coil and plug by keeping them in the glovebox as spares for emergencies. Good luck! - David
 

·
Registered
Joined
·
4 Posts
I had a saga with my 2013 that sounded alot like this.
Mine was the timing chain. I did get codes with it but it wasn't every time.
Truck went to ford 4 times and a turbo wastegate later it's been good since.

Knock on wood.(y)

Edit: Truck is a 19 Supercrew with 3.5 EB.
[/QUOTE]
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #9 ·
I had a saga with my 2013 that sounded alot like this.
Mine was the timing chain. I did get codes with it but it wasn't every time.
Truck went to ford 4 times and a turbo wastegate later it's been good since.
Did you have to replace the timing chain then? was it loose or misaligned?
 

·
Registered
Joined
·
4 Posts
Did you have to replace the timing chain then? was it loose or misaligned?
Yes It did have to be replaced. Big job.
The chain got stretched enough, truck would not get up and go. lazy pull with studdering sometimes.

They weren't even sure it was gonna fix the probelm but after the wastegate did nothing that's was the next thing.
Dealership had to consult their pros to figure it out.
 

·
Premium Member
2022 Powergrid KingRanch in Sparkle White
Joined
·
13,729 Posts
Your 2019 had a stretched chain at how many miles?

Sent from my SM-G988U using Tapatalk
 

·
Premium Member
2022 Powergrid KingRanch in Sparkle White
Joined
·
13,729 Posts
Oh. I wasn't expecting 80,000 miles on a 2019.

It's a little less surprising, but still not as common as chain stretch on the previous generation 3.5

Or at least I HOPE stretched timing chains don't become a common report on forums in the future. (not counting trucks heavily modified to make big power. Even the Gen2 redesign probably comes up short there)

Sent from my SM-G988U using Tapatalk
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #15 ·
Quick update guys, Dealership phoned my yesterday and after reviewing their data logs, they noticed that the throttle position voltage was bouncing around more than it should have been, so they ordered a new throttle body and will be replacing it today. If it is the throttle body that is acting up, then that would explain why changing drive modes had a little bit of an effect on the hesitation/jerking. I'll let you know if this fixes it.
 

·
Registered
Joined
·
6 Posts
Mine does it every now and then. Goes away with a simple reflash. I ended up buying a Edge tuner so I could reflash myself. No explanation why, but it works.

Sent from my SM-G975U using Tapatalk
 

·
Registered
Joined
·
4 Posts
Mine does it every now and then. Goes away with a simple reflash. I ended up buying a Edge tuner so I could reflash myself. No explanation why, but it works.

Sent from my SM-G975U using Tapatalk
I would guess by reflashing your ecm the sensors with the timing chain have to relearn the issue.
If in fact you have the same probelm as I did.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #19 ·
Well... dealer replaced the TB on Friday, after we picked it up it drove great that night, but then on Saturday and Sunday it was right back at it, so now it's back at the dealership. Hopefully they can figure this out.
 

·
Registered
Joined
·
59 Posts
Discussion Starter · #20 ·
Mine does it every now and then. Goes away with a simple reflash. I ended up buying a Edge tuner so I could reflash myself. No explanation why, but it works.

Sent from my SM-G975U using Tapatalk
When you say "reflash" what exactly do you mean? Are you tuned and just returning to stock?
 
1 - 20 of 52 Posts
Top