F150 Ecoboost Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I put the key in and turned...all the gauge lighting, beepings, (normal things) all happen. But the truck won't start. Starter doesn't engage. Only hear clicking (inside cab at fuse panel and in fuse panel under hood). Called my brother (part man at Ford dealership), he had me try something that one of the techs told him to try. Sat in my truck with the door shut, key in ignition for 1 min to try and reset anti-theft...no luck...can someone give me some help PLEASE. Next option is towing to dealership...
 

·
Registered
Joined
·
5,138 Posts
Did you try boosting it?
 

·
Registered
Joined
·
322 Posts
Left the lights on once, same thing happened, all lights and bells, but just clicks when I turned the key, jumped the truck and all was good. Seems this trucks have an internal lockout that when the battery gets to low, it cuts out ignition to keep emergency things running, in aviation it's called an emergency buss.
 
  • Like
Reactions: JoelLeJune

·
Registered
Joined
·
5 Posts
Discussion Starter #4
I had it jumped off of another truck for about 10 minutes and still nothing.
 

·
Registered
Joined
·
28 Posts
I just had this happen to my truck. I was able to manually start it by jumping the starter (holding a screw driver across the positive and negative terminals on the starter). When I brought it into the dealership turned out my power control module was toast which they fixed under warranty. The starter is a pain to get to but u can access it from under the truck on the pass side almost directly under the firewall


Sent from my SM-G925W8 using Tapatalk
 

·
Registered
Joined
·
5 Posts
Discussion Starter #6
So i got it running...turns out it was a fuse in the wrong space. I had an issue with fog lights and while I was looking for the problem, it accidentally put a fuse back in the wrong spot...yea...i feel like an idiot!!!!!!! But the truck is running and I didn't have to spend a fortune!!!!!
 

·
Registered
Joined
·
5,138 Posts
Thanks for the update. Glad it now works.
 
1 - 7 of 7 Posts
Top