F150 Ecoboost Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter #1
Truck finally made it to shop now through holidays and I was moving (Not with the 2.7. had to use my 94 with 5.0).After Ford ran me through a series of "oil consumption" tests, ran my engine down to less than 2 qts of oil (its OK by Fords word to run on small amounts of oil) they have come to the conclusion it needs heads. This problem started at the factory but now they want to ram it down my throat.
It does not smoke but on occaision but is at about 1 quart per 700 miles now, if heads why doesnt it smoke all the time. The engine shudders, Ford says they cant duplicate, rough idle, they cant duplicate. My dealer is 80 miles away and not another near.
I was told they were going to replace the engine, wasnt going to make me happy but at least then it should have been done and any collatteral damages covered, now they want to replace the heads (their Master Tech thought it was a 4cyl) and re test the truck.
Good luck with your Fords, I was raised in a Ford dealer and drove them most of my life....this is the last one.
 

·
Registered
Joined
·
355 Posts
So... This has been going on for a month now. Have you contacted Ford corporate at all, like many people have suggested? If the local dealership is not working with you to resolve the problem, escalate it to somebody who WILL resolve your problem.

If you aren't willing to make a phone call, stop *****ing. I'm sure you're very frustrated, but I think every one of your posts reads exactly the same. Your truck is consuming oil, the stupid dealership isn't helping, and screw Ford...

Time to 'man up' as they say, and do what it takes to solve the problem instead of making multiple pointless threads.
 
  • Like
Reactions: greg hazlett

·
Registered
Joined
·
9 Posts
Discussion Starter #3
No, actually its 4 months now, yes Ford is involved, has been, HOWEVER, to "try" something, then give it back to the customer to see if it "works" because they "think" its the heads is a little stupid to me. Sorry for being redundant, I just believe in standing behind your product, they are not and the calls up the ladder go staraight back to no one that cares. I actually use my trucks, one that I cant use for four months might as well be a brick.
 

·
Registered
Joined
·
355 Posts
Send a PM to the forum user on here FordService and they should get back to you with some questions. They'll probably want to know your VIN, local dealership, and the vitals of your truck (mileage, miles driven per month, etc.) and some of the history. They should be able to escalate to a Ford regional manager who will help you out and work with your local dealership to get you taken care of.

I hope that you don't have to take this to court in order to get it resolved, as that just drags it out and costs everyone way more $$ than it should. I do agree the local dealership should be doing a better job of standing behind the trucks they're selling. But again, hopefully the regional rep will step in and make these problems go away.
 

·
Registered
Joined
·
4,033 Posts
Could be time to eject!
Had to with my 04 Nissan Titan, no shame in it.
Sometimes you get a POS regardless which manufacturer.....and when the stealership PLUS the manufacturer leave you high and dry.....well, it's time to jump ship.
Sorry to hear about your severe agrees to disagrees with Ford.
Good luck....just stay away from the French-errrrrrrr Ecodiesel?

Sent from my SM-N900V using Tapatalk
 

·
Registered
Joined
·
665 Posts
Sorry I may have missed it but what do you consider a reasonable resolution?
 
1 - 8 of 8 Posts
Top