F150 Ecoboost Forum banner
1 - 7 of 7 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
So I noticed this morning a fresh stain on the driveway as I backed out. It has a redish tint to it but does not feel or smell like transmission fluid, more like oil. Going to take it to my dealer today and see what they say. Has anyone else had this problem?
 

·
Registered
Joined
·
1,529 Posts
I have not, but please let us know what the dealer finds. What is your current mileage and approximately where was the stain located under your vehicle?

SPPD
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Will do, 3600 miles on it. It appeared to be slightly off to the passenger side towards the back of the engine compartment, but my driveway is on a pretty good incline so it could have run back and dripped. I couldn't see anything underneath with just a quick look.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #4 ·
Just picked up my truck from the dealer. Was a transmission leak at the connector at the rear of the bulkhead. Had this same issue with my 2010, known issue and TSB corrected the issue.
 

·
Registered
Joined
·
1,529 Posts
Just picked up my truck from the dealer. Was a transmission leak at the connector at the rear of the bulkhead. Had this same issue with my 2010, known issue and TSB corrected the issue.
I am glad they fixed you up quickly!

SPPD
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #6 ·
Me too! Too bad the guy who brought it around thought it was ok to park near the wall and just let go of the door when it opened. Bounced it off the metal wall and chipped the paint all up, then tried to just say sorry and walk off. Told him I don't think so, got the service advisor and it will be fixed soon. Gotta love people!
 

·
Registered
Joined
·
18 Posts
My EcoBeast had this problem as well. A known TSB kit the dealer has to order (if not on site) to fix it properly.
 
1 - 7 of 7 Posts
Top