F150 Ecoboost Forum banner

161 - 168 of 168 Posts

·
Registered
Joined
·
7,186 Posts
Happy New Year everyone!

I'm actually getting married today and heading to PR tomorrow for quick honeymoon before the Army wants me back at Ft. Bragg Jan 6.

If anyone has further info that I can use to diagnose my truck issues using MityVac, datalog or changing anything, please let me know. I'd greatly appreciate it.
Congrats! I think you need to just focus on driving the truck normally for a while and get a 1000+ mile average for MPG.
 
  • Like
Reactions: snakebitten

·
Registered
Joined
·
175 Posts
Discussion Starter #162
Thanks guys. Will do.
164552
 

·
Registered
Joined
·
175 Posts
Discussion Starter #163
It would be awesome if someone could get back to me on the correct prune ration of the round disc, one way check valve that goes from the intake manifold to the 6” spherical ball on the passenger side. Thank you all so much for all your help.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #164
I wanted to close this issue out.

The problem happened immediately after I installed the FR intercooler. It had been about a year of poor performance, poor mileage and high duty cycles for this engine including moving and towing cross country.

Finally, after finding a full set of vacuum hoses and boost solenoids (2011) the boost, power, the pep came back. Not sure what it was but it wasn’t the intercooler but something weak in my system popped. Anyway, boost and power came Back for about a week before new manifold leak showed itself by chirping and showing carbon. This is new as I checked this apart of my differential diagnosis earlier this year. I think after all the miles and abuse I put on the truck, the weak links in the chain are starting to reveal themselves one by one.

anyway, boost solenoids and vacuum tubes fixed this issue.

Thank you for everyone’s help.
 

·
Registered
Joined
·
7,186 Posts
I wanted to close this issue out.

The problem happened immediately after I installed the FR intercooler. It had been about a year of poor performance, poor mileage and high duty cycles for this engine including moving and towing cross country.

Finally, after finding a full set of vacuum hoses and boost solenoids (2011) the boost, power, the pep came back. Not sure what it was but it wasn’t the intercooler but something weak in my system popped. Anyway, boost and power came Back for about a week before new manifold leak showed itself by chirping and showing carbon. This is new as I checked this apart of my differential diagnosis earlier this year. I think after all the miles and abuse I put on the truck, the weak links in the chain are starting to reveal themselves one by one.

anyway, boost solenoids and vacuum tubes fixed this issue.

Thank you for everyone’s help.
Unfortunately the manifold leaks happen to the best of us who've never really beat on it either.

Sent from my SM-G960W using Tapatalk
 

·
Registered
Joined
·
5,350 Posts
Yup. Just did my second manifold replacement.
 

·
Registered
Joined
·
175 Posts
Discussion Starter #168
Yup. Just did my second manifold replacement.
If you know anyone in PNW that could potentially guide me on this, I think I’ll upgrade manifolds, turbo and downpipe all in the same go. Any advice is appreciated
 
161 - 168 of 168 Posts
Top