F150 Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have 2013 f150 ecoboost. i have the upr mega can install. I live in Maine so there are cold winters here. I have had multiple issues with the can and possible the valves in the hoses freezing. when this happens truck will smoke out of the exhaust pretty heavily. this past weekend i took a trip to Canada where the weather was about 0 degrees for about 3 days. took about 250 miles to get there and of course i couldnt empty the can when i got there. the next morning i started truck and of course it was smoking. it ended up smoking for about 10 minutes at idle and the started to clear up. attempt to drive and as soon as engine made boost engine started chugging and smoking in engine bay. had oil all over right side turbo. (still not sure where oil came from, assuming pressure in crank case blew oil out of a seal) shut engine off and heard loud pressure release out of intake. i assume it came from crank case and through can/piping to charge pipe. let sit for 10minutes and started and smoke was gone and ran fine. i ended up having to take can off in hotel parking lot bring inside and thaw to drain. i made the 250 mile trip back home and had to remove and thaw can when i got back also.

So my question is- Is there any other customers having this issue or is my can defective? spent a lot of money for this thing and is kinda pointless if you cant use it in cold weather and its going to damage engine.

[/QUOTE]

*update. after thawing can for 2 hours assuming it was frozen from the 250 mile trip back and 0 degree weather. the can was empty. so no its not even catching anything.
 

·
Registered
Joined
·
399 Posts
Have you taken the can apart and cleaned it? I have the regular size upr can and every 6 months I take it apart and clean it. The internals have a way of working themselves loose. The last time I took it apart I sealed all connections with pipe tape... Hopefully that fixes it.

Sent from my Nexus 6P using Tapatalk
 

·
Registered
Joined
·
1,045 Posts
You might want to check the check valves. UPR had some issues with check valves awhile back.
 

·
Registered
Joined
·
23 Posts
You had "stupid" questions when you first joined, I guarantee it. Assholes like you who think they own the place because they have been here awhile make me lol.

This is a forum, not an archive. What do you care if someone starts a thread that has been discussed before?

I've read your posts. Not all 5,000 of course, as unlike you, I have a life away from my keyboard or phone.
 

·
Registered
Joined
·
4,033 Posts
OP.....just relax, he's like well-like that stepbrother you might or might not have had?-lol

Sent from my SM-N900V using Tapatalk
 
1 - 9 of 9 Posts
Top