F150 Ecoboost Forum banner

1 - 9 of 9 Posts

·
Registered
Joined
·
333 Posts
Discussion Starter #1
Started my truck 2 days ago it displayed a notification saying "check fuel inlet sensor or something". My truck goes to the dealer on monday morning weather permitting. The truck shows absolutely no signs of working incorrectly. The easy fuel flap opens and closes like it should. I have a feeling the senor has malfunctioned. Does anyone have any info on this issue? I will take pictures if needed.
 

·
Registered
Joined
·
5,639 Posts
Started my truck 2 days ago it displayed a notification saying "check fuel inlet sensor or something". My truck goes to the dealer on monday morning weather permitting. The truck shows absolutely no signs of working incorrectly. The easy fuel flap opens and closes like it should. I have a feeling the senor has malfunctioned. Does anyone have any info on this issue? I will take pictures if needed.
I had same thing about a month ago, I looked at owners manual and said to insert and remove the plastic filler thing a couple times. It didn't clear when I did that but on the steering wheel I hit the reset button and it went away And hasn't came back since.
 

·
Registered
Joined
·
1,028 Posts
Started my truck 2 days ago it displayed a notification saying "check fuel inlet sensor or something". My truck goes to the dealer on monday morning weather permitting. The truck shows absolutely no signs of working incorrectly. The easy fuel flap opens and closes like it should. I have a feeling the senor has malfunctioned. Does anyone have any info on this issue? I will take pictures if needed.
Did you make it in to the dealership today, Eboost14? What's the current mileage on your truck?

Crystal
 

·
Registered
Joined
·
2,793 Posts
Check out this video, may help. Flap probably isn't sealing 100%. Sirikenewtron Has some sage advice in this regard as well.

 

·
Registered
Joined
·
333 Posts
Discussion Starter #5
Did you make it in to the dealership today, Eboost14? What's the current mileage on your truck? Crystal
I got my truck back from the dealership this morning. I was told there was some sort of "evap leak" somewhere. However, I had to much gas in my truck for them to provide a definite diagnoses. So they ended up "blowing out the lines" and resetting the computer. According to them if the error reappears or a check engine light appears there is infact an issue some where. Otherwise they said it is as simple as the easy fill flap was not closing completely. They did point out sometimes using a gas pump which the nozzle is to narrow to open the easy fill cap can trigger some problems....this happened to me prior to the light coming on.

My truck is coming up 17k miles.

Sent from my iPhone using F150 EcoBoost
 

·
Registered
Joined
·
333 Posts
Discussion Starter #6
Check out this video, may help. Flap probably isn't sealing 100%. Sirikenewtron Has some sage advice in this regard as well.

Great help! thank you! this tracks a lot with what my service manger at Ford was trying to explain lol haha.
 

·
Registered
Joined
·
2,793 Posts
I was told there was some sort of "evap leak" somewhere.
Ya, Evap leak means the computer is sensing the fuel tank is not holding pressure. Usually always means filler cap is not sealed all the way. With the new EZ fuel just means the flapper probably needs to be cleaned a little.

Check the gasketing material and spring on door to your fuel filler, make sure the door opens and closes completely. It's supposed to seal the filler from any dust/dirt from getting in there. If that is not making a good seal, or the spring for the door is weak some stuff may be getting by and causing the problem.
 

·
Registered
Joined
·
2,793 Posts
1 - 9 of 9 Posts
Top