F150 Ecoboost Forum banner
Status
Not open for further replies.
1 - 12 of 12 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
I have 2013 FX4 and the little 4" screen on the dash displays one of selections called "Gauge Mode". On the first selection it shows the transmission temp on the other selection it is blank - is this normal?
 

·
Registered
Joined
·
19 Posts
Yes It would be, but think same guy who came up with the bumper design for not protecting the intercooler may have had input on it.
I just installed an aftermarket turbo boost / vac guage on mine along with the bumper billet insert.
 

·
Registered
Joined
·
850 Posts
Where did you mount those gauges? Could you post some pics?

Yes It would be, but think same guy who came up with the bumper design for not protecting the intercooler may have had input on it.
I just installed an aftermarket turbo boost / vac guage on mine along with the bumper billet insert.
 

·
Registered
Joined
·
24 Posts
Would dumber still be like me checking it constantly to see if something was added?
:rolleyes: lmao to your comment, as I found myself going to the gauge again today, (4th or 5th time) thinking to myself, the other stuff is here I just can't find it. A true waste, there should be boost, water temp, etc., they did a good job on the drive train and off road stuff, just not much love the power plant.
 

·
Registered
Joined
·
19 Posts
My truck and just a couple of upgrades. Kicker speakers in all doors (cause ford factory speakers were crappy. replaced two within two months under warranty)
and new Vac/Boost guage . will post pics of bumper billet and flat rain guards that look factory.

Land vehicle Vehicle Car Tire Automotive tire
Auto part Fashion accessory Vehicle Engine
Land vehicle Vehicle Car Gauge Steering wheel
 
1 - 12 of 12 Posts
Status
Not open for further replies.
Top