F150 Ecoboost Forum banner
1 - 8 of 8 Posts

·
Registered
2018 Ford F-150 4WD Lariat Sport, SuperCrew, 4WD, 3.5 EcoBoost, Special Edition Package
Joined
·
39 Posts
Discussion Starter · #1 ·
I'm picking up the truck this morning but I thought I'd ask if there's anything particular I should check before leaving the lot. I'll listen for weird noises and if the rattle is still present; I'll look at the engine to see if I can find anything disconnected or loose, but is there anything else I should do? I've read the complaints of overheating after the phaser replacement so I'll drive it around in both the city and highway.
Thanks
 

·
Premium Member
17 Lariat SCLB Max Tow 4x4
Joined
·
980 Posts
Operate the engine at various rpm’s and loads. Make sure it works as it should. Check for leaks around front cover/valve covers and go from there…
 

·
Registered
2018 Ford F-150 4WD Lariat Sport, SuperCrew, 4WD, 3.5 EcoBoost, Special Edition Package
Joined
·
39 Posts
Discussion Starter · #3 ·
Everything is good so far. The startup rattle is totally gone and everything seems to have been put back together correctly. I talk more about this on another thread I created.
 

·
Premium Member
Joined
·
603 Posts
I just had mine done also. I have a '20 3.5.
My number one concern was making sure they changed the oil and had the coolant filled. They did and all is good.
Of course, I changed the oil again when I got it home because who knows what they put in it. I prefer Mobil 1. The problem with this oil change was Lou Ferrigno putting on my oil filter! It took a pipe wrench to get it off:mad:
I never had the loud phasers but they did make a faint noise for the first 3 minutes during a cold start then it went away like turning off a switch. After the "repair" I still have the faint noise but it only last about a minute then stops.
I have no leaks or overheating so far. The transmission doesn't have the hard 4th to 3rd downshift any longer?! I am happy so far:giggle:
 

·
Registered
2019 f150 3.5 ecoboost crew cab 4x4 heavy tow package fx4 6.5' bed highly modified
Joined
·
6,602 Posts
I never had the loud phasers but they did make a faint noise for the first 3 minutes during a cold start then it went away like turning off a switch. After the "repair" I still have the faint noise but it only last about a minute then stops.
:giggle:
that’s normal although three minutes seems a little long, one minute is totally normal though. All the 2nd Gen 3.5 ecoboost I come across do it.


Sent from my iPhone using Tapatalk
 

·
Premium Member
17 Lariat SCLB Max Tow 4x4
Joined
·
980 Posts
Could that 1 to 3 minute noise be waste gate rattle?
My wastegates seem to rattle until it idles down it seems. Then she’s nice and quiet.
 
  • Like
Reactions: snakebitten

·
Premium Member
Joined
·
603 Posts
that’s normal although three minutes seems a little long, one minute is totally normal though. All the 2nd Gen 3.5 ecoboost I come across do it.


Sent from my iPhone using Tapatalk
I'm glad that's normal. I haven't heard any other 3.5's up close during a cold start. My daughters 2.7 in her '150 doesn't make a sound lol
 
1 - 8 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top