F150 Ecoboost Forum banner
1 - 4 of 4 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
my ecoboost is flashing some lights. i bought it as a wreck, fixed all the wreck damage and now im working on getting everything running right. it shows some other lights too. brakes, service advanced trac which im not sure how to do. so any info on that would me helpful.

its got oil. seems to be getting oil up to the heads. i just dont know why its saying low oil pressure. anyone had this problem or access to a service manual.?
 

·
Registered
Joined
·
1,529 Posts
Welcome to the F150 Ecoboost Forum!

Sounds like you have a long road ahead fixing up that wreck. I can't help, but there are a lot of really great folks on here that may be able to assist you.

Regards,

SPPD
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #3 ·
Here's a photo of how the truck looked when i bought it off ebay as a builder. I bought it out of california I'm from arizona so it was a sight unseen which I don't recommend doing. It doesn't look so bad in the photo. bent frame, destroyed frame horns. bent control arm. needless to say im in well over my budget at this point. and im still having problems.

At this point right now im in it for about 14900 including my purchase price. I was shooting for 13000 or less. My only thought on this oil pressure problem so far is maybe the sending unit? which hopefully is external. Also if anyone has any knowledge about where I can get a service manual for it online I would really appreciate it.

 

·
Registered
Joined
·
64 Posts
Make sure the sending unit didn't come disconnected from the work done to it. It's an easy check to see if your oil pressure is indeed lacking. Go buy a 30 dollar oil pressure gauge and hook it up long enough to see if you have oil pressure.
 
1 - 4 of 4 Posts
Top