F150 Ecoboost Forum banner
1 - 16 of 16 Posts

·
Registered
Joined
·
37 Posts
Discussion Starter · #1 ·
Ok, so I just got my Edge CS tuner today, and plugged it into my truck. I changed the tire size and gear ratio on it and then decided to go ahead and flash a program. I followed the directions on the screen but when it was finished, my truck wouldn't start. Crap. I thought about reflashing the stock program, but now my programmer won't communicate with truck and edge's customer service is closed right now. My information center keeps popping up system start failure. Can anybody help me?
 

·
Registered
Joined
·
89 Posts
man i wish you would have listened to me...

you have no file loaded into your truck at all right now. something lost communication during upload. hopefully edge has awesome off site customer service, otherwise you'll be paying for a tow to the dealer to upload a program into your truck again. you will get charged for that too. and they will definitely add a note under the file for the truck stating the ECU program has a history of tampering.
 

·
Registered
Joined
·
859 Posts
Before updating the truck, did you check to make sure the tuner had the most recent software/tunes on it?

Ok, so I just got my Edge CS tuner today, and plugged it into my truck. I changed the tire size and gear ratio on it and then decided to go ahead and flash a program. I followed the directions on the screen but when it was finished, my truck wouldn't start. Crap. I thought about reflashing the stock program, but now my programmer won't communicate with truck and edge's customer service is closed right now. My information center keeps popping up system start failure. Can anybody help me?
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #4 ·
Slow, yes, I know. As soon as my ignition wouldn't turn over our emails went through my head about a hundred miles an hour. I got on the phone with edge at 9:03 my time (8:00 mountain time, which is where they are) and I was able to flash the stock program to my unit and get my truck started back up. I then had to update the unit to the newest firmware and was able to program my truck. All is right in the universe, but apparently Edge has known about this issue with new Ford trucks (specifically the ecoboost) locking you out of the system after flashing a tune and yet they don't have 24hr customer support...:confused:
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #7 ·
Talk to slow before you buy, he has a tuner you can buy that will give you some serious numbers with only regular unleaded gas.
 

·
Registered
Joined
·
859 Posts
Are you still running the Edge? How's it working for you? Notice a difference?

Talk to slow before you buy, he has a tuner you can buy that will give you some serious numbers with only regular unleaded gas.
 

·
Registered
Joined
·
37 Posts
Discussion Starter · #10 ·
Are you still running the Edge? How's it working for you? Notice a difference?
Yes, I'm still running it and boy do I notice a difference! I haven't tried the tow setting yet, just the economy setting and the performance setting. The performance setting is super fun and gets me great fuel mileage as well. I'm thinking about saving up and getting the tuner that slow was talking to me about and then selling the edge. You just can't knock the numbers that slow is getting from his truck with just regular unleaded gas. But overall I'm happy with the edge. If you do get it, don't try and install it until 8am mountain time on a weekday, as the first time you hook a programmer up to your truck it'll probably lock you out and you'll have to talk to their customer service and flash a stock code to your programmer before you can proceed. Just FYI from someone with a little experience in it :p.
 

·
Premium Member
Joined
·
2,425 Posts
At first I was like "dammnnnn he's calling out the OP!"
then I was like "dammnnnn he's calling out himself!"
 

·
Registered
Joined
·
9,640 Posts
At first I was like "dammnnnn he's calling out the OP!"
then I was like "dammnnnn he's calling out himself!"
At first, I was like, holy thread necromancer!
Lol

Sent from my SCH-I545 using Tapatalk
 

·
Registered
Joined
·
9,640 Posts
It's dead, just let it rot....lol

Sent from my SCH-I545 using Tapatalk
 
1 - 16 of 16 Posts
Top