F150 Ecoboost Forum banner
1 - 3 of 3 Posts

· Registered
Joined
·
48 Posts
Discussion Starter · #1 ·
if you have seen this post you need to know that Im trying to get info from different forum, thanks for your understanding

Hi, my 2014 3.5 eco have just started to make the awfull noise at cold start up . This is the same noise that you can hear all over the f150 forum from a 3.5 engine cam phasers .

I am a winter texan from Canada , I am near Mission Texas and I wonder if I can postpone the repair for a few months and let say approximately 3000 miles ?

I have read that the cost for the front job including chain guide phasers etc etc cost around 3500.00 USD at the dealership ... for us Canadian spending the winter in the USA that mean we have to add 35% to that due to our weak monopoly Canadian money ... so the total cost would be around $4725.00 Canadian

Now you understand why Ill try to see if I can delay the repair.

so if you have some experience tell me for how long and or for how many miles your 3.5 is making noise at start up and which symptom is developing if any and if the engine risk of .destroying itself.
on our way home in April lol

Thanks to all

btw if that matter I am pulling a 7500 lbs trailer

Long shot here ... any experience with Spike ford in Mission Texas ?
 

· Registered
Joined
·
48 Posts
Discussion Starter · #6 ·
What about just doing the phasers ? No need to remove the front cover and that would made the job a lot easier, especially if one do it before getting a code , in my book not having a code is having the timing chains not stretched out of spec , what do you think ?
 

· Registered
Joined
·
48 Posts
Discussion Starter · #8 ·
thanks to all for your input guys, so far the noise didn't reappear , so I would be happy if the sound didn't return for the next 2 months and 4000km .... finger crossed :) tomorrow oil change, i'm going back to FL500S and going QS euro 5w40 just to put the chance on my side to stay in grade until Im back home
 
1 - 3 of 3 Posts
Top