F150 Ecoboost Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
427 Posts
Discussion Starter #1
I installed a mak catless y-pipe yesterday on my '13 fx4. I already had the tune for the new pipe before the install although im still waiting for a tune from the company that I prefer more. First off it doesnt feel near as strong as it did before and im clueless as to why and maybe they all sound like mine but it just sounds like a massive amount of airflow coming from under the passenger seat. Maybe its just the turbos and I can just hear them a lot better now without the cats im not sure. It just doesnt feel right when I get in it a little. Maybe it just needs a little while to break in? Any thoughts or suggestions would be greatly appreciated. It just makes me worry when I get in the throttle and all I can hear is a lot of air blowing. Ive already checked and re tightened everything twice. Do all you guys that have catless downpipes hear that air blowing like I do. Another thing all I have is a straight through glasspack muffler and its all three inch so its pretty much just a straight pipe from the turbos back. Maybe I need to add a different muffler? Sorry for the long thread ive just put a lot of money in this truck between buying the truck and all the mods so again any help would be highly appreciated
 

·
Registered
Joined
·
2,413 Posts
Took me 10hrs.. How long you fought for?




Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
838 Posts
Took me 10hrs.. How long you fought for? Sent from my SAMSUNG-SGH-I337 using Tapatalk
Why!?!?!? That seems longer then it should be
 

·
Registered
Joined
·
427 Posts
Discussion Starter #4
About 4 but a buddy of mine has a lift so that made it 10 times easier. I couldnt imagine doing it laying on my back in the driveway
 

·
Registered
Joined
·
427 Posts
Discussion Starter #5
How did yalls trucks run the day of and after the install
 

·
Registered
Joined
·
2,413 Posts
On my back .. Im so sore !! Runs fine. I Ran my best at the track today. You might wanna make sure you not leaking at your turbos.

Sent from my SAMSUNG-SGH-I337 using Tapatalk
 

·
Registered
Joined
·
427 Posts
Discussion Starter #8
It may be the turbos it only sounds like that when im driving it doesnt do it when I rev it up so it may be the turbos since they are probably louder when under a load
 
1 - 8 of 8 Posts
Top