F150 Ecoboost Forum banner

1 - 16 of 16 Posts

·
Registered
Joined
·
18 Posts
Discussion Starter #1
I have a 2011 F150 3.5L. The left side turn signal and brake light are not working. I've replaced bulbs, tested sockets, checked fuses and relays. The relay works when placed on the right side but it does not seem to be getting power on the left side. Please help me out I'm going crazy.
 

·
Registered
Joined
·
868 Posts
if i had access to some electrical prints i could tell you where to start lookin but i dont have any.
some time here in the near future i hope to have a book with them in.

i really would be guessing if the turns are part of an integrated module or not.
have you tried checking power and see where it is lost, i know that easier askd than done because you have to pull covers and expose wires and contacts to do it.
it might be as simple as a contact inside the turn signal lever.
 

·
Registered
Joined
·
868 Posts
actually now that i thought about it im really not sure how these work but i am leaning toward an open circuit in the turn signal if your brake light doesnt work either

here is my reasoning when 12v is applied to the circuit the brake light would be lit constant
the turn signal flasher would open and close the circuit causing the light to flash on and off if that flasher is stuck open then the circuit never comes on at all

of course if the dam lights are controlled by an integrated module then this theory is not valid
 

·
Registered
Joined
·
18 Posts
Discussion Starter #5
Actually I bought a service manual DVD which is the one that ford uses. It tells you the steps in trouble shooting the problem But there some steps that you need to do with a special computer that ford has. I've tried a [email protected]@@ snap on computer that a mechanic friend has and had no luck. Supposedly the Body Control Module stops working if there's a short, and needs to be reset or replaced. I've checked all wires and contacts and it seems that it's coming from inside after the switch to where the fuses and relays are. So the only thing I can think is the BCM. I've take everything apart including steering wheel and MF switch. I'm thinking of just taking it to the dealer on Thursday because I've spent so much time on this.
 

·
Registered
Joined
·
265 Posts
Hey man ya I've seen this before, if you hook it up to an IDS, Ford scan tool, and clear codes and perform a BCM self test it usually fixes the problem, if not then hopefully a code will pop up
 

·
Registered
Joined
·
18 Posts
Discussion Starter #7
Hey thanks yes I believe that's strictly a dealership deal only their scanners reset that. We tried looking for it with a good snap on scanner and couldn't find anything
 

·
Registered
Joined
·
1,028 Posts
Hey thanks yes I believe that's strictly a dealership deal only their scanners reset that. We tried looking for it with a good snap on scanner and couldn't find anything
FireMed,

My name is Ashley and I'm the new Ford Service rep here on the forum. If you do decide to head to the dealer tomorrow, let me know. PM me your name, phone number, VIN, mileage, and dealer info, and I'll see how I can help!

Ashley
 

·
Registered
Joined
·
18 Posts
Discussion Starter #9
Oh and mileage is 31xxx u can get you the exact number later In the day if you need it I'm at work I'm a firefighter paramedic that's why I'm writing so late LOL I get off at 8am and will send you the exact mileage. Again thanks for your help
 

·
Registered
Joined
·
18 Posts
Discussion Starter #10
Update on my problem, well it turns out that as per dealership it is the Body Control Module. The diagnosis was 300 cause they stated they had to remove the dashboard. The control module was 450 and 175 for a tire pressure sensor so in all after taxes about a grand. They also told me they don't know if the brake light will work because the car since it's a recovered theft has a different differential than the one it's supposed to have. So I'll fix all that with the dealer and found a used differential with 31000 miles for 1500. We will see if that does it
 

·
Administrator
Joined
·
7,862 Posts
My buddy has a 2012 FX4 EcoBoost and just went over 38000 miles on it and said his left turn signal randomly turns on when he is driving and when he actually turns it on that sometimes it doesn't shut off.

He just told me he might be using his arms here in a bit. lol
 

·
Registered
Joined
·
868 Posts
Update on my problem, well it turns out that as per dealership it is the Body Control Module. The diagnosis was 300 cause they stated they had to remove the dashboard. The control module was 450 and 175 for a tire pressure sensor so in all after taxes about a grand. They also told me they don't know if the brake light will work because the car since it's a recovered theft has a different differential than the one it's supposed to have. So I'll fix all that with the dealer and found a used differential with 31000 miles for 1500. We will see if that does it
so wait a minute you got 31,000 miles and the dealership got you for a grand to fix the light issue with a module and a tire sensor.
what happened to your warranty ?
 

·
Registered
Joined
·
9,641 Posts
so wait a minute you got 31,000 miles and the dealership got you for a grand to fix the light issue with a module and a tire sensor.
what happened to your warranty ?
He's got a 2011, maybe time ran out...
 

·
Registered
Joined
·
18 Posts
Discussion Starter #15
So it was the BCM on my truck I didn't want to take the risk of ordering it myself and spending 100 to have them program it so I had to fork out 900 for a tire pressure sensor and the BCM. But oh well at least now it works
 
1 - 16 of 16 Posts
Top