F150 Ecoboost Forum banner
1 - 17 of 17 Posts

· Registered
2013 Ford F-150 Lariat Kodiak Brown 4x4 with 3.5 Ecoboost
Joined
·
15 Posts
Discussion Starter · #1 ·
This is a pic of what im talking about. I cant find anywhere that looks like its leaking but something is all crusty on that intake hose, almost looks like dried coolant but i have no coolant loss.
Automotive tire Motor vehicle Pipeline transport Automotive exterior Gas
 

· Registered
2017 F150 XL 2WD 2.7, with some extra stuff!
Joined
·
2,130 Posts
Any problem with temperatures? How full is the coolant expansion tank?
It may have got hot and over flowed the tank. Leaving no visible leak after cooling down. KM
 
  • Like
Reactions: stereotype one

· Registered
2013 Ford F-150 Lariat Kodiak Brown 4x4 with 3.5 Ecoboost
Joined
·
15 Posts
Discussion Starter · #7 ·
Any problem with temperatures? How full is the coolant expansion tank?
It may have got hot and over flowed the tank. Leaving no visible leak after cooling down. KM
Temps stay fine, coolant level never drops, it looks old but idk I just noticed it. I need to clean it off ans see if it builds up again
 

· Registered
2017 F150 XL 2WD 2.7, with some extra stuff!
Joined
·
2,130 Posts
Temps stay fine, coolant level never drops, it looks old but idk I just noticed it. I need to clean it off ans see if it builds up again
Not so much overheating as over filling the expansion tank as the engine warms up. KM
 

· Moderstrator
Joined
·
4,863 Posts
I don't think so, I believe that has been left hanging so that he can get a better view. I should say I'm assuming. I think everyone has probably seen that, I don't know why none of us has mentioned it.
 

· Registered
2017 F150 XL 2WD 2.7, with some extra stuff!
Joined
·
2,130 Posts
The OP did not mention or complain about the running condition. For myself, figured OP knew or pulled the sensor just to check. KM
 

· Registered
2014 screw 4x4 ecoboost
Joined
·
69 Posts
I would have thought OP pulled it to see if it seeped through and went inside the intake.
 

· Registered
Joined
·
3,176 Posts
I say put the cleaned sensor back in then spray simple green on the engine, use soft brush on the bad spots, rinse dry and move on. Check every so often to see if it returns.
 
1 - 17 of 17 Posts
Top