F150 Ecoboost Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hey everyone, hoping I could get some insight or help on this one. My first Ford Truck it's a 2017 ford F-150 eco boost 3.5-liter V-6 Engine.
So on the front of the engine the hose was disconnected and it caused a significant loss of power especially going up hills it made it a somewhat of a struggle but I noticed it after a month or so and realized it and reconnected it and it made a big difference in speed What exactly is this? I have attached a picture. Also I have a alot of oil leaking to the point there's none in so I refilled it and put dye in it as well and ran it for 30 minutes and drove it but I don't see any leak or will it take longer for the dye to come out and could it be related to that hose being disconnected?
172640
 

Attachments

·
Premium Member
2013 XLT 302A 145" Screw
Joined
·
3,220 Posts
Hmmm. Hmmm indeed. So very hmmm.
Welcome to the forum, ‘Koda‘ !
 

·
Premium Member
2015 Lariat 4WD
Joined
·
380 Posts
Year and specs of vehicle will help.

That is your intake...well intake side of....you know what it is...is this a joke?

Kinda scratching my head here. Not sure what "Koda" is but...

Will wait to reply more.
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
Year and specs of vehicle will help.

That is your intake...well intake side of....you know what it is...is this a joke?

Kinda scratching my head here. Not sure what "Koda" is but...

Will wait to reply more.
I said the year is a 2017 Ford f150 XLT. Yeah I'm not sure what it is but I could ask you about HMMWV's but I'm not sure you're not familiar with that and can make you feel dumb about that? If you don't know what that is it's a military vehicle but since you don't know I'm not gonna judge you for that. I came here for information not to be ridiculed.
 

·
Registered
Joined
·
161 Posts
That big hose is your main air intake. Without it connected, you would have big power loss and probably some check engine lights to go along with it.

As for the oil, if someone was negligent enough to leave the intake disconnected then perhaps they also failed to put the right amount of oil in to begin with.

Do you have oil stains, dripping, etc. that could point to a source?

Sent from my SM-N976U using Tapatalk
 

·
Premium Member
2015 Lariat 4WD
Joined
·
380 Posts
Hey now I wasn’t trying to make you feel ridiculed at all. And I am very familiar with the most uncomfortable “combat” vehicle the US DOD seems to love. Hated those things.

My apologies if I came across that way.


Sent from my mobile phone that I barely understand and have to have my teenage kids show me how to work…is it bad I miss my StarTac?
 

·
Registered
2016 Ford F-150 XLT 2.7 Ecoboost 3.55 Axle
Joined
·
622 Posts
Hey everyone, hoping I could get some insight or help on this one. My first Ford Truck it's a 2017 ford F-150 eco boost 3.5-liter V-6 Engine.
So on the front of the engine the hose was disconnected and it caused a significant loss of power especially going up hills it made it a somewhat of a struggle but I noticed it after a month or so and realized it and reconnected it and it made a big difference in speed What exactly is this? I have attached a picture. Also I have a alot of oil leaking to the point there's none in so I refilled it and put dye in it as well and ran it for 30 minutes and drove it but I don't see any leak or will it take longer for the dye to come out and could it be related to that hose being disconnected? View attachment 172640
Lol! That’s you’re intake! Of course you felt almost no power, the truck wouldn’t be getting any boost!
 

·
Premium Member
2015 Lariat 4WD
Joined
·
380 Posts
Seriously, I read and re-read my post and I can see where it came across as me being a dick. Again, I apologize. Was not my intention.
 

·
Premium Member
2013 XLT 302A 145" Screw
Joined
·
3,220 Posts
I said the year is a 2017 Ford f150 XLT. Yeah I'm not sure what it is but I could ask you about HMMWV's but I'm not sure you're not familiar with that and can make you feel dumb about that? If you don't know what that is it's a military vehicle but since you don't know I'm not gonna judge you for that. I came here for information not to be ridiculed.
How long did you operate the engine while it was dry of oil ?
 

·
Premium Member
2013 XLT 302A 145" Screw
Joined
·
3,220 Posts
IDK. I'm still sittin here like hmmm.
 
  • Like
Reactions: smitty6153

·
Registered
Joined
·
2,071 Posts
Yeah if that was disconnected a month highly likely motor would be junk. All that unfiltered debris straight into combustion chamber. Can’t see it lasting long.


Sent from my iPhone using Tapatalk
 
1 - 12 of 12 Posts
Top