F150 Ecoboost Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
I was heading back home from a 600 mile round trip camping trip last week pulling our travel trailer when we started to climb a hill, truck was on cruise control, transmission was in 5th gear. All of a sudden I had an almost complete loss of power, engine was running really rough and jerking truck, seemed like the transmission over down sifted HARD. Not sure what gear it was in when this was happening. I eased to the shoulder and stopped. Truck started to run smooth again and was in first gear. No warning /error messages. All this transpired in less than 1 minute. I proceeded to continue on, truck ran fine rest of way home (100 miles) smooth running and shifting fine ever since and never happened before. Truck is a 2012 F 150 3.5 V6 Ecoboost.
Any ideas?
 

·
Registered
Joined
·
2,800 Posts
Condensation ingestion? The issue is common for unmodified 11-14 trucks when accelerating after driving steady at highway speeds for a while, especially if its cold, humid, or rainy.

Also check your sparkplug gaps.
 

·
Registered
Joined
·
4,069 Posts
Drill the weep hole in your CAC. Check all your coil red tabs make sure they haven't worked loose....which can make the truck think its mis-firing.
Do a throttlebody reset.
Sometimes when you run 85-87 octane you get some garbage fuel.
Check for any vacuum leaks etc....
If course pull your plugs to see what condition their in
Screenshot_20210504-150306_Facebook.jpg


Sent from my SM-G965U1 using Tapatalk
 

·
Premium Member
Joined
·
1,428 Posts
I agree above being that it may have been condensation.

But if no CEL - the truck probably detected some False KR when it downshifted. As in something rattled and the truck pulled timing thinking it was detonation.

I have had in the past where my hitch would actually rattle and the truck pulled timing thinking something was wrong.
 

·
Registered
13 FX2 SCREW
Joined
·
60 Posts
I was heading back home from a 600 mile round trip camping trip last week pulling our travel trailer when we started to climb a hill, truck was on cruise control, transmission was in 5th gear. All of a sudden I had an almost complete loss of power, engine was running really rough and jerking truck, seemed like the transmission over down sifted HARD. Not sure what gear it was in when this was happening. I eased to the shoulder and stopped. Truck started to run smooth again and was in first gear. No warning /error messages. All this transpired in less than 1 minute. I proceeded to continue on, truck ran fine rest of way home (100 miles) smooth running and shifting fine ever since and never happened before. Truck is a 2012 F 150 3.5 V6 Ecoboost.
Any ideas?
Have you had the transmission recall done?

If im not mistaken those were the exact symptoms that caused the recall.
Being in a high gear at highway speed, the rear trans speed sensor would lose signal and force the transmission to 1st gear.
 
1 - 5 of 5 Posts
Top