F150 Ecoboost Forum banner

1 - 20 of 30 Posts

·
Registered
Joined
·
124 Posts
Discussion Starter #1
I was wondering if anyone has lost mpg after install of there 170 thermostat? I changed out my thermostat and I have been getting pretty crappy MPG.

I've only done 2 changes to my truck besides a tune. Tune should get me better mpg. Changes are brisk plugs gapped to .030 and the 170 thermostat.

I had better mpg after my tune and after theses other changes the mpg went to ****. I get 16.6 mpg hwy cruising 70 on 3.55 gears and city 11.8-12.7
 

·
Registered
Joined
·
346 Posts
I was wondering if anyone has lost mpg after install of there 170 thermostat? I changed out my thermostat and I have been getting pretty crappy MPG.

I've only done 2 changes to my truck besides a tune. Tune should get me better mpg. Changes are brisk plugs gapped to .030 and the 170 thermostat.

I had better mpg after my tune and after theses other changes the mpg went to ****. I get 16.6 mpg hwy cruising 70 on 3.55 gears and city 11.8-12.7
Sounds strange. My mileage stayed exactly the same with the 170... anything else you can think of?

Sent from my VS980 4G using Tapatalk
 

·
Registered
Joined
·
9,641 Posts
Does your odometer match the mile markers on the highway and/or GPS?
 

·
Registered
Joined
·
13,052 Posts
Ok I will bite. What tune did you get?


Sent from my white iPad3 in a RED smart case using an app called Tapatalk
 

·
Registered
Joined
·
124 Posts
Discussion Starter #10
Does your odometer match the mile markers on the highway and/or GPS?
I downloaded an app called max speed and it matched pretty well when testing at constant 60mph.

I had livernios when I saw it was bad and thought it was the tune since I had them update it for the 170t, then changed to SSI trex but still have the same issue.
 

·
Registered
Joined
·
13,052 Posts
#trex = wheels spinning. Case closed.


Sent from my white iPad3 in a RED smart case using an app called Tapatalk
 

·
Registered
Joined
·
124 Posts
Discussion Starter #12
#trex = wheels spinning. Case closed.


Sent from my white iPad3 in a RED smart case using an app called Tapatalk
I still had the issue with livernios. I have an MPT on order that I'm waiting on. But I'm def not getting anywhere near my usual mpg. I'll try taking the tune off to see if my mpg goes up I guess just to cancel that out.
 

·
Registered
Joined
·
13,052 Posts
very strange. I just figure cause it was a fast tune. Now you go zoom zoom.


Sent from my white iPad3 in a RED smart case using an app called Tapatalk
 

·
Registered
Joined
·
741 Posts
Are you still getting the same range out of each tank? The computer might be off, i never go by what the computer says i hand calculate mine
 

·
Registered
Joined
·
124 Posts
Discussion Starter #15
Are you still getting the same range out of each tank? The computer might be off, i never go by what the computer says i hand calculate mine
I was thinking of doing that next but couldn't figure out the sudden change.. but it is wasting more fuel.

How accurate is the trip a/b counter?
 

·
Registered
Joined
·
9,641 Posts
I was thinking of doing that next but couldn't figure out the sudden change.. but it is wasting more fuel.

How accurate is the trip a/b counter?
Should be as accurate as your odometer. Just try to use the same pump at the same station and stop on the same click each time. It's OCD, but if you aren't consistent, it'll be hard to figure out which variable is throwing it out.
 

·
Registered
Joined
·
741 Posts
Are you sure the plugs were gapped rite, torqued to proper spec?
 

·
Registered
Joined
·
741 Posts
I just cant see a low temp tstat and properly gapped plugs affecting mileage
 

·
Registered
Joined
·
741 Posts
Do you have any check engine lights? Is it missing or not running rite?
 
1 - 20 of 30 Posts
Top