F150 Ecoboost Forum banner

1 - 17 of 17 Posts

·
Registered
Joined
·
1,529 Posts
BTT!

Very important information for those with high humidity falter issue!

SPPD
 

·
Registered
Joined
·
142 Posts
Great post! Will be useful to many.
 

·
Registered
Joined
·
537 Posts
I wonder if this is a true fix or another Band-Aid to cover/mask the problem?

Maybe I am just a little skeptical because all this looks to do it move the air block/deflector from the top of the intercooler to the lower section of the IC. I guess another red flag is that the new piece attaches with a double sided sticky tape like adhesion principal.

I guess time will tell one way or the other. Those who do go in and get the TSB preformed please keep the rest of us up to date.
 

·
Registered
Joined
·
360 Posts
Do TSB's like this get applied on the production line once they are released? i.e... if my truck is built in the next month, will it come with the top or the new bottom air deflector??
 

·
Registered
Joined
·
4 Posts
Do TSB's like this get applied on the production line once they are released? i.e... if my truck is built in the next month, will it come with the top or the new bottom air deflector??
My 2012 was built with the top shield on it.

There is a difference in 11,12's & 13's. The 11 & 12's had the blow off valve on the turbo's. In the 13's it was moved to the CAC which may account fewer problems with them. I know from my experience's they haven't corrected this issue even with all the TSB's so far.

This is going on for 3 Years now. I am starting to believe they will never properly fix this. In the last few years I've owned 2 Bronco's, 2 Expedition's, 2 F-150's & 3 Taurus's. I've talked to a lot of people from Ford and can't get an honest answer about this. This will be my last Ford product if it isn't taken care of properly instead of the band aid's they are using now to hide the problem. Granted this is a difficult issue, but if they are to continue using the Ecoboost technology they have to get to the bottom of it.

My best advice to someone thinking of buying an Ecoboost vehicle is not to get it at the present time as they are not taking care of the people like me who have been loyal Ford customers for years. Something has changed at Ford in the last few years and not for the better.
 

·
Registered
Joined
·
360 Posts
Thanks for your opinion.

So will 2013's being built now come with this new bottom air deflector?
 

·
Registered
Joined
·
29 Posts
GREAT...let's block a large chunk of the cooling surface with a plate! Why not just remove the CAC and make the motor a hot air???
 

·
Registered
Joined
·
26 Posts
Had this happen to me for the second time today. 2013 FX4. Driving in the rain from Miami to Tampa, noticed the mileage was dropping from around 19.5 down to around 18, accelerated from about 75 mph hard enough to have the tranny downshift to 5th, engine lost power, check engine light started flashing, felt like it was missing on several cylinders. After about 1 minute, it cleared and was fine for balance of trip.
Interesting that it happened the same way several weeks ago on the same trip in the same conditions. I had been driving at 75mph for about 3 hours both times.
 

·
Registered
Joined
·
9,641 Posts
Had this happen to me for the second time today. 2013 FX4. Driving in the rain from Miami to Tampa, noticed the mileage was dropping from around 19.5 down to around 18, accelerated from about 75 mph hard enough to have the tranny downshift to 5th, engine lost power, check engine light started flashing, felt like it was missing on several cylinders. After about 1 minute, it cleared and was fine for balance of trip.
Interesting that it happened the same way several weeks ago on the same trip in the same conditions. I had been driving at 75mph for about 3 hours both times.
Have you checked your spark plug gaps?
Curious if you have the tighter gaps a lot of us are running, and still experienced this.
 

·
Registered
Joined
·
4 Posts
I have two 2012 F150 Trucks. Mine has the ecoboost engine and my wife's has the 5.0. At approximately 17k miles, I too started experiencing the shudder at hard acceleration and has happened 4 times w/i 1500 miles. Contacted dealer and awaiting resolution. The better half's 5.0 has experienced no mechanical issues but has begun having an issue with the air bag light coming on out of the blue while she is driving. Then the next time she fires it up, no issues. I have owned several makes of vehicles in my day and thought (when first purchased) that these two were at the top of my all time liked list... Having second thoughts. First post even though I have read comments for months.. Learned so much from everyone and hope I will be able to contribute.
 

·
Registered
Joined
·
565 Posts
Thats odd, my 2013 was built in August and did not come with that metal cover on the CAC, it came with the plastic shield over the top.
i also have a 13 not sure when it was built but it doesnt have that shield and i pretty sure the bov is on the turbos
 

·
Registered
Joined
·
873 Posts
13 here with the cover on the top as well. No issues so far but it does have the rough idle scenario. I prolly need to have the spark plug gaps checked.
 
1 - 17 of 17 Posts
Top