F150 Ecoboost Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
Hi Guys,

My 2011 Ecoboost with 180,000kms has 0 air blowing from the vents and I can't seem to figure it out.

Before this, the truck would either blow full speed, or no speed at all, and it didn't matter what speed I had the control set to. Because of this I checked the Blower Motor Resistor and that doesn't seem to be the issue. Sometimes I would hit a bump in the road and my air would go from nothing to full speed. I had no issue with the temperature control (cold blew cold, hot blew hot), driver/passenger climate controls were accurate, I hear no clicking from the blender door, and the heated/cooled seats still work properly.

No matter what climate setting I put it to, literally no air comes out, no windshield defrost, nothing on Auto or Manual speed control.

I'm pretty capable of fixing most things on my truck, I've done most of the work to date, but I can't figure this out of the life of me. And with Winter on it's way up here in Canada, I will definitely need my defroster.

PLEASE HELP!
 

·
Registered
Joined
·
211 Posts
It could just be the climate control knob, the one that control how much air gets blown. I am not sure if they can be swapped. I say crack it open and see what you find. Could be bad connection inside the spindle of the knob.

Sent from my Pixel XL using Tapatalk
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Thanks for the responce, I will check that out.

My only thinking is that when I adjust the speed or the temperature, the display changes correctly with it. Think it's possible for the display to change correctly but not relay the message to the blower motor?
 

·
Registered
Joined
·
3,983 Posts
@Demaray77, I would start by feeding the blower motor 12v (alligator clips hooked up to a power pack or a battery) and see if it comes on. If it comes on, then move on...
Seeing as you have the fancy climate control, I do not believe your truck has a blower motor resistor. It should have a blower motor control module, still hooked up in the same spot as the resistor would go.
I had to replace mine last year. Ordered the Motorcraft YH1829part from Rockauto (was cheaper than up here even with shipping).

Check here to see which yours looks like. 2011 FORD F-150 3.5L V6 Turbocharged Blower Motor Control Module / Resistor | RockAuto

Don't forget to check the Rockauto thread in the vendors area here on the forum for 5% discount code.
 

·
Registered
Joined
·
64 Posts
seems that I have this exact same issue on my new to me 2014. cooled seats work but the vents wont blow any air at all. its 90 degrees here in florida and i bout sweated by taters off today! PLEASE HELP!
 

·
Registered
Joined
·
64 Posts
man that was fast. I sure appreciate it. any idea where its located? I`m gonna call my local dealer now to see if its a stock item.
 
1 - 11 of 11 Posts
Top