F150 Ecoboost Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
121 Posts
Discussion Starter · #1 ·
What are normal engine temps for the gen 1 2.7 eco? I put a new tstat that is rated at 180° but crusing on the highway unloaded my temps are 230° and at idle there 218° I had it retuned for it also and my cooling fans are on fullbore and not cycling It doesnt seem right to me at all and im going to assume that the new tstat i put in isnt working properly or and im just assuming that because of the temps?
 

Attachments

·
Registered
Joined
·
121 Posts
Discussion Starter · #5 ·
Running those temps, especially after a procedure that requires the coolant loop to be opened (dumped), would have me suspecting air pocket.
Or as Justinjs might be asking, a faulty thermostat.
I have not had a temp spike which would lead me to or have a concern of an air pocket, and i installed the tstat yesterday afternoon never checked the temps after install till the drive to work this morning cause i left my tuner at the house like a dingdong. As for the tstat being faulty thats what im leading towards cause its a motorad brand and i had this issue before on my old vehicle it didnt last long
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #7 ·
View attachment 175826 \

This is from a summer 80+ degree day. Once up to temp mine runs 199-205 degrees F. It is in a light weight under 4500 pound 2wd F150.
OEM thermostat coolant was changed earlier in the summer and system flushed.KM
Alright im gonna try and burp the system since i didnt do that and see what happens and if it continues to be a problem ill put the oem tstat back in
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #10 ·
Mine was also motorad and it was 208-221 normally. A few weeks ago I exchanged it for a new motorcraft one and it sits at 188-190 all day.
Yeah the tstat is bad wont even open at all, so im putting in a new motorcraft and not messing with the system any more not worth the risk
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #12 · (Edited)
Thanks for the help and responses guys. Problem is cured the tstat was defective and i put a new motorcraft tstat in and everything is normal now, i will no longer buy motorad tstats cause this isnt the first time for me with that brand and its for sure going to be my last. I just hope i didnt do any damage to anything cause i drove roughly 100miles with the problem
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #13 ·
Mine was also motorad and it was 208-221 normally. A few weeks ago I exchanged it for a new motorcraft one and it sits at 188-190 all day.
Im running 200-207 with the new one, wonder if i can get better temps by disabling the grill shutter with forscan if it can be done
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #17 ·
Having to replace your stat yet again would suck, but Motorcraft does make a 180 stat for these - RT1225, available from RockAuto for about $23. I'm running one (haven't even had my tune adjusted for it yet, so the fans still don't come on until higher temps) and it works as claimed. Opens at 180, full open at 188.

Burping these things isn't a time thing. It's a number of events thing. If you don't have a vacuum system, you'll need to monitor the level in the bottle for a few weeks. I'd bet money you didn't get every single pocket out.
I herd of that part number but someone said that it was not a 180° tstat but i will take your word for it and see what i come up with. There was a bumch of coolant that cameout with the tstat and with the history i had with the brand im not gonna take anychances a motor is to expensive to take a chance on a cheap part
 
  • Like
Reactions: Justinjs

·
Registered
Joined
·
121 Posts
Discussion Starter · #19 ·
Just bought one two weeks ago and installed it myself. It was stamped 180F, and the ECT/CHT temps I'm seeing on the cluster and via my Livewire back that up.

And yes, you'll lose a ton of coolant when you pull the stat - honestly, that's how I do coolant changes. Just make sure to dry the belts off before you crank the truck back up. And this is a perfect time to move to MC Yellow coolant if you're still running that orange junk.
Did you buy the tstat from the dealer or rockauto? Im taking your word on it but i looked it up and it Pops up as a 190° and 180° temp. And what wrong with the orange coolant?
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #21 ·
Rockauto. And yes, it says 190 on their site, but it's a 180 stat. Even stamped that way.

As far as orange, there's a zillion threads on Google. Short story is that it has a tendency to create sludge and that sludge tends to go straight to the heater core... an expensive and time-consuming fix. Supposedly, yellow doesn't do that. You can mix yellow and orange but, when I did my stat, I dumped everything out I could, flushed with VC-1, flushed 3x with distilled water, then refilled the system with yellow concentrate and distilled water to get to the proper mixture (since it's effectively impossible to empty the entire system) which I confirmed with a refractometer. I'll be doing my wife's Explorer the same way in the near future.
Alright as for the part number will that fit a 2017 2.7? And i didnt know about the orange coolant that new news to me guess you learn something everyday
 
  • Like
Reactions: butthead

·
Registered
Joined
·
121 Posts
Discussion Starter · #23 ·
I don't know about the 2.7. I thought they were the same, but I'd encourage you to verify.
What year truck do you have and i assume you have the 3.5?
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #25 ·
What year truck do you have and i assume you have the 3.5?
10-4 and yes itll fit just double checked. Now i gotta find one cause rock auto doesnt carry them anymore
 

·
Registered
Joined
·
121 Posts
Discussion Starter · #26 ·
Yep, 2018 3.5EB.
10-4 just double checked it will fit, and i looked into the coolant thing and i guess it wouldnt hurt to do just gotta find a brand that is p-oat coolant
 
1 - 14 of 14 Posts
Top