F150 Ecoboost Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Updated the My Sync software on the ol' F150 last week, and have had the most frustrating problems ever since. Not sure if it's coincidental on the timing and the issue is related to something else or not...

Sometimes my volume buttons change my radio stations...the "track forward" button will switch to the preset to the left, as will the "track back" button. If I hold down on the VolUp button for about five seconds, this usually resolves those issues. However, the primary issue that renders My Sync to be virtually useless is that the VOICE button brings up the redial screen for the last contact I spoke with. Every. Single. Time.

I've done a master reset on the system, I've disconnected my phone from Bluetooth...even then, I get prompted to add a phone instead of using voice commands.

ITS DRIVING ME BONKERS

Has anyone else had the same experiences????
 

·
Registered
Joined
·
523 Posts
I haven't experienced those issues. Do you also have the MFT system?

Have you attempted to delete your phone and re-add it? I'm guessing here.

Does the problem exist with, without, your phone being connected via bluetooth?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #4
Yes, it's MFT. The whole shibang. My apologies, have always just referred to it as Sync.

Seems to happen with or without phone. Have deleted it and still experience the same symptoms. Seems to work ok this morning on the way to work. Was able to use the voice button, but was following up with the redial screen.
 

·
Registered
Joined
·
2,625 Posts
Go into the settings and do a master reset. It can be found under 'System Settings' and should reset everything. If you are still having issues you could unhook the battery for thirty minutes. REMEMBER this will reset every setting you have ever put on your truck. Including what the transmission has learned from your driving style.

If that doesn't work, I would advise taking it to the dealer.


Sent from my iPhone using Tapatalk 2
 

·
Registered
Joined
·
523 Posts
I'm relatively certain the master reset on the MFT system doesn't involve any of the powertrain control systems. Thought being you can perform a master reset on the MFT system while driving down the road. Additionally the Accessory Protocol Interface Module (APIM) quit working and rendered the MFT system inoperable in my wife's 2012 Edge. The result being a blank screen. However the vehicle powertrain was unaffected.

I would think most of all powertrain dependencies are associated with the PCM and TCM.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
For anyone that is interested...I seem to have narrowed it down to, oddly enough, turning the wheel to left. I started keeping track of things - when it worked, when it didn't work, what I just did, etc. Turns out that when I am turning 90 degrees, say at a stop light onto another road, the voice button stops working altogether or starts redialing. It corrects itself sometimes when I make a 90 degree turn to the right, but not always.

Pretty sure this is a physical problem that will have to be resolved by the dealership. I am able to replicate it at any time.
 

·
Premium Member
Joined
·
414 Posts
Very interesting! My voice button was intermittently useless then would work for a few days then not again. Tried the master reset and it didn't help either.

When it tried to redial my phone I contacted my dealer, Manning Ford in DeKalb and they performed a hard reset. Didn't help so set up an appointment to leave the truck. Further diagnosis found a failing SYNC module which they ordered up. Came in Monday, left the truck today and picked it up after lunch. Put all my settings back in and its working fine now.

Headed out on another 400 mile R/T this weekend and I'll bet I'll enjoy the sound system a whole lot better now!

Have to put kudos out to Alex, Patrick and Trish along with Jerry in parts for the great and helpful service! Guess that's why Boostie is my 8th rig bought there!
 

·
Premium Member
Joined
·
414 Posts
Back home from the trip. Ahh, good to have my music back!

Very interesting! My voice button was intermittently useless then would work for a few days then not again. Tried the master reset and it didn't help either.

When it tried to redial my phone I contacted my dealer, Manning Ford in DeKalb and they performed a hard reset. Didn't help so set up an appointment to leave the truck. Further diagnosis found a failing SYNC module which they ordered up. Came in Monday, left the truck today and picked it up after lunch. Put all my settings back in and its working fine now.

Headed out on another 400 mile R/T this weekend and I'll bet I'll enjoy the sound system a whole lot better now!

Have to put kudos out to Alex, Patrick and Trish along with Jerry in parts for the great and helpful service! Guess that's why Boostie is my 8th rig bought there!
 
1 - 10 of 10 Posts
Top