F150 Ecoboost Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
2 years ago, the dealership replaced my sliding rear window on warranty because my rear defrost stopped working. Now my truck is off warranty and the same problem pops up again. I know many people (including Toyota owners) have had this issue and I want to fix it myself.

Any ideas of how to solve this problem?
 

·
Registered
Joined
·
319 Posts
Silly as this sounds, but my rear window was frozen stuck with a tiny little gap from being fully closed and wouldn't allow the heater to turn on. I could not see it being open. My rear window freezes all the time.
 

·
Premium Member
Joined
·
799 Posts
If you haven't yet..... type "Rear Defrost" in the search function. There are multiple multiple threads covering several different problems and resolution. Give you a start anyway. I have not had yet but hope not to have this issue. Good luck.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #4
thanks doesnt help. Mostly people complaining about it with zero solutions of how to repair aside from take to dealership. thanks though.
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
yes cuz it needs to make contact to complete the circuit. Mine isnt frozen just doesnt work and I am looking for solutions on how to fix.
 

·
Premium Member
Joined
·
799 Posts
There is one there somewhere were the flat circuit broke by the window...he repaired it somehow with a jumper. Under a cover back there???? I know I read it. Did you pull the cover off and inspect circuit?
 

·
Premium Member
Joined
·
799 Posts

·
Premium Member
Joined
·
799 Posts

·
Premium Member
Joined
·
799 Posts
 

·
Premium Member
Joined
·
799 Posts
There's more out there but you're going to have to pin point exact break in circuit.....best I got....
 
1 - 10 of 10 Posts
Top